MiniTiouner v2 failing all tests

Discussion about the MiniTiouner board and the MiniTiouner Digital ATV Receive Software. See also http://www.vivadatv.org/index.php
Mike_G8EEY
Posts: 4
Joined: Fri May 01, 2015 6:28 pm

MiniTiouner v2 failing all tests

Post by Mike_G8EEY » Thu Feb 27, 2020 4:27 pm

I have just built a Minitiouner v2 using board, NIM and USB minimodule from BATC, 10K resistor added to USB module. All voltages are within spec and current is around 300mA.
I allowed a windows 10 laptop to setup usb drivers and powered up the Minitiouner. Running TestMyMinitiouner (latest) fails completely. Am I looking for hardware or software failure?

Mini Test gives:

D2XX test -OK Device Present... NIM : ?????
___________________________________________
DLL version: 3.2.14
we have found 2 device (s)
.............................................................
device 0:
device named: FT2232H MiniModule A
..............................................................
device 1:
device named: FT2232H MiniModule B
>>>>>>>>>> NO MiniTiouner connected to USB MASTER!
<<<<<<<<<<<
>>>>>>>>>> NO MiniTiouner-Pro connected to USB AUX!
<<<<<<<<<<<
_________________________________________________
________

G4EWJ
Posts: 826
Joined: Wed Feb 17, 2010 10:11 am

Re: MiniTiouner v2 failing all tests

Post by G4EWJ » Fri Feb 28, 2020 1:41 pm

I tried removing the NIM on my v2 to see if yours isn't seeing the NIM properly, but I don't get the same output as you.

Can you post screen shots after starting TestMyMiniTiouner_V2_0a, after clicking I2C Master init (NIM) and after clicking Test NIM.

Brian

Mike_G8EEY
Posts: 4
Joined: Fri May 01, 2015 6:28 pm

Re: MiniTiouner v2 failing all tests

Post by Mike_G8EEY » Fri Feb 28, 2020 4:41 pm

Hi Brian,

Running TestMyMinitiouner gives: file

Clicking I2C Master init (NIM) and clicking Test NIM do nothing - greyed out.

Mike.
Attachments
TESTMYMINITIOUNER RESULT.png
TESTMYMINITIOUNER RESULT.png (38.54 KiB) Viewed 1668 times

g0mjw
Posts: 1271
Joined: Sat Sep 20, 2014 9:15 am

Re: MiniTiouner v2 failing all tests

Post by g0mjw » Fri Feb 28, 2020 7:29 pm

It is not seeing the NIM. Check and recheck the soldering, power supply voltages etc.

Mike

G0EID
Posts: 25
Joined: Thu Oct 17, 2013 3:19 pm

Re: MiniTiouner v2 failing all tests

Post by G0EID » Fri Feb 28, 2020 10:27 pm

Hi Mike'
I think your problem is that the FT2232 USB module has lost it's configuration?
See how your device names do not contain NIM in their names.
I have attached a snapshot from my TestMyMiniTiouner_V2_0a..
See how the difference in the device names found in my snapshot, attached.
On on the BATC wiki page, there's a link to the instructions for instaling the FTProg module programming software and the template XML file to apply, once you have the FTProg software installed.

https://wiki.batc.org.uk/MiniTiouner_hardware_Version_2

73
Dave
Attachments
NIMTest.png
NIMTest.png (61.45 KiB) Viewed 1624 times

G0EID
Posts: 25
Joined: Thu Oct 17, 2013 3:19 pm

Re: MiniTiouner v2 failing all tests

Post by G0EID » Sat Feb 29, 2020 1:08 am

Hi Mike,
Do you have a DigiLite board attached to your system?
If you do, then that's where the "FT2232H MiniModule" device name is coming from..

I have tested this myself, TestMyMiniTiouner_V2_0a reports the same as yours, with only a DigiLite board connected..
I also tested with a MiniTiouner and a DigiLite board connected, TestMyMiniTiouner_V2_0a reports four devices & seems select the correct devices when running the NIM tests.
So I think that if you do also have a DigiLite board connected, then your MiniTiouner has a cable or hardware fault?
Expect that you should see four devices configured, same as mine?

What do you see when you run TestMyMiniTiouner_V2_0a with _only_ your MiniTiouner connected?
If you still see "FT2232H MiniModule" device names, then I think your FT2232H module needs reprogramming?

73
Dave
Attachments
With DigiLite module only.
With DigiLite module only.
NIMTest2_DL_Only.png (45.12 KiB) Viewed 1601 times
With DigiLite and NIM Tuner attached.
With DigiLite and NIM Tuner attached.
NIMTest2.png (61.23 KiB) Viewed 1601 times

g0mjw
Posts: 1271
Joined: Sat Sep 20, 2014 9:15 am

Re: MiniTiouner v2 failing all tests

Post by g0mjw » Sat Feb 29, 2020 8:28 am

Good catch Dave, I didn't expect someone to be testing a Minitiouner with a Digilite. I had thought these were independent boxes that took video in and produced DVB-S out with no PC required. Turns out that's not what they were at all and they do contain the same USB module. How Minitioune behaves if one is plugged in as well as a minitiouner might be something that needs looking at. I would hope it would ignore it, select the correct device etc.

But if it can't find the minitiouner, then there might be several reasons. The first is bad USB cables which can so often cause the detection problems. Ones that come from Ebay only intended for charging are prime examples. They will not work, or work very poorly.

The FT module from BATC should have been pre-programmed. They don't normally just forget what they are. If it is not programmed (e.g obtained from elsewhere) you will need to use FT Prog and follow the instructions on the Wiki. It's not difficult.

I still think there is a possibility of a communication problem with the NIM. This can be caused by a problem on the I2C communication bus due to a bad socket, an unsoldered pin, a short or wrong value resistor terminating the bus, or power supply problem. There must have been over a hundred built by now so most issues will have come to light. Time for a troubleshooting guide maybe.

Mike

Mike_G8EEY
Posts: 4
Joined: Fri May 01, 2015 6:28 pm

Re: MiniTiouner v2 failing all tests

Post by Mike_G8EEY » Sat Feb 29, 2020 3:25 pm

Thanks for all the suggestions.
It is built as the basic v2 board as per the instructions, no digilite or other add-ons. Supplies all checked and re-checked ok. I now wish that I had used sockets for the NIM rather than soldering, although this can cause other problems. The usb cable is the newer version from Lindy. I will try the FTprog method first, if the NIM is faulty I doubt the board will survive its removal.
Mike.

G0EID
Posts: 25
Joined: Thu Oct 17, 2013 3:19 pm

Re: MiniTiouner v2 failing all tests

Post by G0EID » Sat Feb 29, 2020 4:00 pm

Hi Mike,
I am reticent to condemn your NIM at this point, as Brian G4EWJ pointed out, even with the NIM removed we do not see the same errors as you?
From the testing that I have done, to try to reproduce your problem, I think the problem is around the USB interface?
If we can discount any confusion with DigiLite.
I think that, either an unprogrammed module or a module with the DigiLite template applied, escaped from the shop?
Hopefully reprogramming will be the solution?
73
Dave

Mike_G8EEY
Posts: 4
Joined: Fri May 01, 2015 6:28 pm

Re: MiniTiouner v2 failing all tests

Post by Mike_G8EEY » Sat Feb 29, 2020 4:10 pm

Success, it seems that the FT2232H module either lost its memory, or was not preprogrammed before dispatch from BATC shop. I2C performance reading 86% on win7 desktop pc. Thanks again to all the helpers.
Mike.

Post Reply

Return to “The MiniTiouner and MiniTioune Digital Receive Software”