Portsdown stream viewer

Discussion about this major DATV Project. See also https://wiki.batc.org.uk/The_Portsdown_Transmitter
g0mjw
Posts: 1173
Joined: Sat Sep 20, 2014 9:15 am

Re: Portsdown stream viewer

Post by g0mjw » Thu Jun 25, 2020 5:38 pm

That would help eliminate the ISP so a good check. It worked for Colin I think.

User avatar
G1LPS Terry
Posts: 139
Joined: Mon Mar 10, 2008 10:33 pm

Re: Portsdown stream viewer

Post by G1LPS Terry » Sat Jun 27, 2020 5:19 pm

Hi Dave
Just for reference Portsdown A27 shows a stream for me today? Portsdown 202006070 doesn't.
If it was an ISP issue, I would have expected both not to work.

I don't have a mobile phone connection I can try. My mobile is paid by work and hotspot is blocked.
Apart from Colin and Clive locally is anyone else having an issue?
Terry

G8GKQ
Site Admin
Posts: 1692
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown stream viewer

Post by G8GKQ » Sat Jun 27, 2020 5:25 pm

Hi Terry

Very strange - my Portsdown 202006070 shows the KM stream perfectly at this time.

Doesn't sound like an ISP issue at your end. I'll do some more investigation.

Dave

G6ZVE
Posts: 5
Joined: Sat May 02, 2020 12:01 pm

Re: Portsdown stream viewer

Post by G6ZVE » Sun Jun 28, 2020 6:08 am

Hi Dave,
I have got the same issue as Terry since i upgraded to the
latest version 202006070 of ports down, all i get now when i want to
view a stream is valid stream detected and the ports down logo.

The previous version 202004302 works fine no problem,thankfully i had a spare
SD card with the old version on it
If it is any help i am on Talk Talk .

Regards
Ian G6ZVE.

User avatar
G1LPS Terry
Posts: 139
Joined: Mon Mar 10, 2008 10:33 pm

Re: Portsdown stream viewer

Post by G1LPS Terry » Sun Jun 28, 2020 11:16 am

Thanks Ian
This was also the case for Clive G4FVP he had the stream on the previous version.
He Updated to check for me and lost it. Only valid stream detected and splash screen. (if you watch carefully you see stream dropped or similar message flash up quickly once)
Portsdown 4 (A27) is still working today.

Regards
Terry

G8GKQ
Site Admin
Posts: 1692
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown stream viewer

Post by G8GKQ » Sun Jun 28, 2020 11:28 am

Hi All

Thanks for tracking down this extra information about the problem. I'll have a look at what I might have broken during the update!

Dave, G8GKQ

G8GKQ
Site Admin
Posts: 1692
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown stream viewer

Post by G8GKQ » Sun Jun 28, 2020 1:27 pm

I think that I may have tracked this one down, but need some help. Please could everyone with this problem:
  1. Log in through ssh, go to the command prompt (Shutdown, Exit to Linux) and then enter the following command:

    Code: Select all

    aplay -l
    Then post the result here (highlight it in Putty - which copies it, and then paste it here).
  2. Return to the touchscreen (you can type

    Code: Select all

    gui
    at the command prompt to do this) and then go to Menu 3 and report whether the Audio out button says "Audio out RPi jack" or "Audio out USB dongle".
  3. Then touch the button to toggle it to the other setting, and try viewing a stream to see if this cures the problem.
Based on all number of reports back, I will try to modify the code so that it works for everybody every time! If you don't report back, it might not work for your particular case - so please do!

Dave, G8GKQ

User avatar
G1LPS Terry
Posts: 139
Joined: Mon Mar 10, 2008 10:33 pm

Re: Portsdown stream viewer

Post by G1LPS Terry » Sun Jun 28, 2020 1:43 pm

Hi Dave
I just tried building a new card today from your github and the stream viewer is now working.
So my result may not be useful


Terry
Attachments
2020_06_28_14_55_41_pi_raspberrypi_.jpg
2020_06_28_14_55_41_pi_raspberrypi_.jpg (34.33 KiB) Viewed 306 times

G6ZVE
Posts: 5
Joined: Sat May 02, 2020 12:01 pm

Re: Portsdown stream viewer

Post by G6ZVE » Sun Jun 28, 2020 7:09 pm

pi@raspberrypi:~ $ aplay -1
aplay: invalid option -- '1'
Try `aplay --help' for more information.
pi@raspberrypi:~ $

The audio out was set to USB dongle,

Changed it to audio out RPI jack and now all my streams are working again.

Thank you Dave.

Regards

Ian G6ZVE.

G8GKQ
Site Admin
Posts: 1692
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown stream viewer

Post by G8GKQ » Sun Jun 28, 2020 7:37 pm

Thanks Ian

Sorry, I should have made clear that it was aplay -l (Lima). Anyway, the fact that selecting the correct output cured it ties in with my theory.

I'll change things in the next update so that selecting the wrong audio output will still play the video.

Dave

Post Reply

Return to “The Portsdown Digital ATV System”