New build with Lime - H264 not working.

Discussion about this major DATV Project. See
Site Admin
Posts: 2138
Joined: Sun Mar 22, 2009 1:21 pm

Re: New build with Lime - H264 not working.

Post by G8GKQ » Mon Apr 15, 2019 6:37 pm

Hi Nick

There do seem to be some issues with the latest release (also reported by G4HIZ), however, I'm struggling to put my finger on them.

As a general rule, S2QPSK modulation (MPEG-2 or H264) works much better that DVB-S. Most of my testing was with DVB-S2 QPSK as this is the mode of choice for QO-100. Also, the EasyCap and Pi Camera modes work better than the static test card or Animated Test Card.

That said, some of the most prolific signals on the satellite (G4KLB and G7JTT) are using this build quite successfully, and I was only able to reproduce the fault condition with DVB-S static test card at 333KS. DVB-S with a Pi Cam worked perfectly for me.

I'll keep looking at it, but perhaps you could try DVB-S2 QPSK and see if it is useable for you. It seems very unlikely to be a LimeSDR issue if MPEG-2 works well. It's almost certainly a software issue that I have been unable to diagnose and solve.

Please persist with MPEG-2 or other modes that work for you and I'll try to make some improvements in the next release.

Dave, G8GKQ

Posts: 112
Joined: Sat Oct 03, 2015 10:09 am

Re: New build with Lime - H264 not working.

Post by Nick » Mon Apr 15, 2019 7:20 pm


To answer your questions:-

I am using a Lime SDR Mini obtained from BATC shop.
I am using a powered USB hub obtained from Pi Hut - this one - ... wer-switch

Based on your reply I went back to basics to try your suggestion of using Ugly mode.

I note that when Preset 4 in menu 1 is selected that the chosen encoding method is H264.

On trying this with the Minitioune I could not get any signal.

To make sure it was working I selected MPEG2 - this selected Test Card for source.

After some adjusting of the pickup wire neat to the Pi I got a perfect display of the test card and 100% signal and carrier lock with nice constellations.

I went back to H264 and could still not get anything - no carrier or timing lock - nothing.

Back to MPEG2 and it was working.

This was tried with a Pi with just the 3.5inck screen attached - as basic as it could be.

As H264 is pre-set when ugly mode is selected I assume this should work.

Is it more critical then MPEG2 to use in ugly mode, or should I have been able to see it easily ?

I am thinking that if I can't use H264 in ugly mode than I am not going to get anywhere using the lime mini, so need to sort this out before trying anymore with to full build.

Also wondering if this could be why with the lime mini build the system is still transmitting when it has been supposedly stopped.



Posts: 112
Joined: Sat Oct 03, 2015 10:09 am

Re: New build with Lime - H264 not working.

Post by Nick » Fri Apr 19, 2019 10:54 am


I obtained a blank SD card and re-built the software from scratch as per instructions on site pages.

This has cured the problem with no H264 transmission - it now works great :D

Somehow it seems that the update I did using the Portsdown Update button got corrupted, not just on one card, but on two different ones.

Anyway, the Portsdown is now complete and finally boxed up.

Many thanks for your work on the software and assistance with this issue Dave - it is most appreciated.


Nick - G4NKV

Posts: 75
Joined: Thu Oct 18, 2018 6:40 am

Re: New build with Lime - H264 not working.

Post by g4hiz » Sat Apr 20, 2019 6:42 am

Hi Nick,

thanks for sharing your experience with the H264 not working and your eventual solution. I had the same issue and following your lead, tried the same solution with success, ie a clean memory card programmed from scratch as per instructions on GitHub and H264 now working !



Posts: 32
Joined: Thu Oct 20, 2011 12:47 pm

Re: New build with Lime - H264 not working.

Post by mm0mgb » Mon Jan 06, 2020 5:49 pm

I might be getting somewhere. with no network cable plugged in it behaved normally but with Ethernet in didnt, think I might be getting issues with stray RF corrupting the pi and the sd card? I'll keep looking


Post Reply

Return to “The Portsdown Digital ATV System”