Update 20181229

Discussion about this major DATV Project. See also https://wiki.batc.org.uk/The_Portsdown_Transmitter
F1SSF
Posts: 53
Joined: Sat Nov 25, 2017 5:14 pm

Update 20181229

Post by F1SSF » Sun Jan 06, 2019 9:11 am

Hi Dave,
Happy new year for you and your familly.
Questions, please, since the update, I have a problem with TestCard.
The reception on Minitioun begins, the picture begins to appear about 1cm, and nothing.
I also have a problem with the input IPTS IN, flux not transmit.
A friend OM also has this problem too.
Somes changes?
73 Franck F1SSF
testcard.PNG
testcard.PNG (16.56 KiB) Viewed 829 times

G8GKQ
Site Admin
Posts: 1091
Joined: Sun Mar 22, 2009 1:21 pm

Re: Update 20181229

Post by G8GKQ » Mon Jan 07, 2019 10:15 am

Hi Franck

Evariste and I know about this problem, which only occurs in Desktop modes (such as the test card) with H264 encoding. I have a fix but need to test it a lot more (it has other effects) before releasing it.

What modulator and symbol rate are you using? We know that it happens with the DATV Express at most SRs https://wiki.batc.org.uk/Controlling_a_ ... imitations.

The interim solution is to use a camera, the video input or animated test card mode; or switch to MPEG-2.

Dave

G8GKQ
Site Admin
Posts: 1091
Joined: Sun Mar 22, 2009 1:21 pm

Re: Update 20181229

Post by G8GKQ » Mon Jan 07, 2019 10:16 am

Franck

IPTS in mode: what modulator are you using? I have not made any changes to that code....

Dave

f8boj
Posts: 1
Joined: Mon Jan 07, 2019 3:48 pm

Re: Update 20181229

Post by f8boj » Mon Jan 07, 2019 4:26 pm

Hello Dave and all
I have the same problem as my friend Franck with the Portsdown to transmit
TESTCARD and PIScreen mode H264 and Mpeg since the update 201812290 + lime
sr500 no problem on the other hand from sr1000 and above no reception on
tutioune-pro otherwise sr1000 image of 2 cm sr1500 and 2000 the transmission
of the portsdown is interrupted once led green once red leds in tutioune-pro
no reception
on the other hand Cam mode c920 and TCANIM and TSfile work perfectly without
problem ...at this moment I have not tested IPTS
previous versions before 201812290 + lime all worked perfectly unfortunately
I have no backup of the old version
73s claude F8BOJ

F1SSF
Posts: 53
Joined: Sat Nov 25, 2017 5:14 pm

Re: Update 20181229

Post by F1SSF » Mon Jan 07, 2019 8:10 pm

Hi Dave
.Evariste and I know about this problem
I am razed, the problem is in good hands ;)
what modulator are you using? I have not made any changes to that code....
No changes about my process: Portsdown IPTS in ,VMIX out, ffmpeg in background. (start with .bat file)
If you have not made any changes, I will do tests again this weekend, and return feedback to you, maybe I made a mistake.
Best 73 Franck F1SSF

F1SSF
Posts: 53
Joined: Sat Nov 25, 2017 5:14 pm

Re: Update 20181229

Post by F1SSF » Thu Jan 10, 2019 5:30 pm

Hi Dave,
I wish I could do downgrade software, to verified if my problem is real.
Is it possible?
73 Franck

G8GKQ
Site Admin
Posts: 1091
Joined: Sun Mar 22, 2009 1:21 pm

Re: Update 20181229

Post by G8GKQ » Thu Jan 10, 2019 10:23 pm

Hi Franck

It is very difficult to downgrade the whole software. To downgrade the file that I think is causing the problem, you need to do the following commands:

Code: Select all

cd /home/pi/rpidatv/scripts
mv a.sh a.201012290.sh
wget https://raw.githubusercontent.com/BritishAmateurTelevisionClub/portsdown/536e59132bbb835c10365b4ee22420f2faf5ae58/scripts/a.sh
chmod +x a.sh
cd ~
rpidatv/scripts/utils/guir.sh
This will take you back to the 201810180 version of a.sh, which is the critical file for playing a TS stream. The last line starts the touchscreen. If you are using the ssh console, instead type:

Code: Select all

rpidatv/scripts/menu.sh menu
Please tread carefully - I haven't tested this, but it might work for you. Please let me know what happens.

Dave, G8GKQ

F1SSF
Posts: 53
Joined: Sat Nov 25, 2017 5:14 pm

Re: Update 20181229

Post by F1SSF » Sat Jan 12, 2019 12:12 pm

Hi Dave,

I have applied you commande line, now:
MPEG2 direct from RPI >> ok from SR333 to SR1000, after not OK
H264 direct from RPI >> ok from SR333 to SR2000

MPEG2 across VMIX/FFMPEG >> don't run
H264 across VMIX/FFMPEG >> run very well, but decoding on Minitioun is more long that before.

I have done an other test, I have write a new SD card, and, exactly same things.
I don't understood, I had not any problem before, and F8BOJ has same things the me.
do others persons report this ?

Best 73 Franck

g0mjw
Posts: 710
Joined: Sat Sep 20, 2014 9:15 am

Re: Update 20181229

Post by g0mjw » Sat Jan 12, 2019 3:27 pm

Hi Dave

In the activity this afternoon it became apparent my C920 no longer works as a Webcam for use at low symbol rates. I am not sure why that might be. Any ideas? Clearly for 2MS+ it's great but I would like to use it at lower rates as a normal webcam.

Mike

G8GKQ
Site Admin
Posts: 1091
Joined: Sun Mar 22, 2009 1:21 pm

Re: Update 20181229

Post by G8GKQ » Sat Jan 12, 2019 4:38 pm

Hi Mike

What video source did you have selected? C920?

Dave

Post Reply

Return to “The Portsdown Digital Transmitter Project”