Portsdown 4 picam OV5647

Discussion about this major DATV Project. See https://wiki.batc.org.uk/The_Portsdown_Transmitter
Post Reply
F4CTZ
Posts: 2
Joined: Mon Jul 08, 2024 4:55 pm

Portsdown 4 picam OV5647

Post by F4CTZ » Mon Jul 08, 2024 5:03 pm

Hello,

I'm trying to use Portsdown4 with a picam V1 (OV5647) but I've never managed to TX using it after following the installation recommanded.

I put "dtoverly=ov5647" and "start_x=1" in the config.txt.

"vcgencmd get_camera" returns me "vcgencmd get_camera supported=1 detected=0 libcamera interfaces=1"
"raspistill" command returns me an error telling me to use legacy stack.

I tried to install libcamera-apps which permits me to see images using "libcamera-hello" but portsdown4 never transmit when I select "Picam" as source.

Any ideas ?

Thnaks a lot for your help,
Best 73's,
Fabien, F4CTZ

G8GKQ
Site Admin
Posts: 2862
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown 4 picam OV5647

Post by G8GKQ » Tue Jul 09, 2024 9:06 am

Fabien

I see that the OV5467 is not the official Raspberry Pi camera, although it claims to be compatible.

The Portsdown 4 has only been tested with the offcial Raspberry Pi Camera V1, V2 and HQ. It does not work with the V3. No other CSI-connected cameras are supported.

If the OV5467 is truly compatible, you should not need to make any modifciations to the config.txt file. So try without the 2 extra lines that you have added (you'll need to reboot).

If that does not work, try with just "dtoverlay=ov5647". Note the correct spelling of dtoverlay - you had it wrong above.

If that does not work, please buy a genuine Raspberry Pi Camera V1 or V2.

Dave, G8GKQ

radiogareth
Posts: 1286
Joined: Wed Jan 06, 2016 9:46 am

Re: Portsdown 4 picam OV5647

Post by radiogareth » Tue Jul 09, 2024 1:57 pm

I have used a cheap copy RPI (marked as a V1.3) and it was fine other than its back-light handling. Now used as a source for the BATC Video Source project and I have fitted 'real' cameras in my PD4's.
The cheap units have 3 SMD transistors on the back like this one eBay item 395358264149 but for not much more a genuine camera can be had such as this eBay item 266886148551.
Very useful for portable work in case your usual camera is left at home or fails....
Gareth

F4CTZ
Posts: 2
Joined: Mon Jul 08, 2024 4:55 pm

Re: Portsdown 4 picam OV5647

Post by F4CTZ » Thu Jul 11, 2024 7:42 am

Hi Dave,

On the following page, you can find a chart that tell us that the OV5647 corresponds to the official camera V1 from Raspberry :
https://www.raspberrypi.com/documentati ... amera.html

I bought this two cameras :
https://www.amazon.fr/dp/B07GNHXGD9
https://www.amazon.fr/AZDelivery-Cam%C3 ... 01M6UCEM5/ (the same as Gareth told)

My mistake was to try to make the RPI driver work by modifying the /boot/config.txt file. But you made a super job that permits Portsdown to work without that. The only problem I still get is that the PiCam Monitor do not work : I think it is for that I came into the modificition of the config.txt. Indeed, before try to transmit, I would like to see the image using Picam monitor but this function never worked here (using webcontrol only) so I never try to transmit...

Now, I removed all lines in config.txt I added (the only one that is mandatory is "dtparam=i2c_arm=on") and when I transmit my lime goes TX and I received images on SDRAngel at the other end with a RTLSDR.

Thanks a lot for your work !

One more question : Is there a way to reduce the very large latency I get on the received images ? I'm using SR250 and FEC 1/2 but it seems to be the same thing with higher SR or FEC.

Best 73's,
Fabien, F4CTZ

Post Reply

Return to “The Portsdown Digital ATV System”