Portsdown & Adalm Pluto / Problems Connecting Using CAT5

Click here to learn more about Amateur TV and the BATC
Forum rules
This forum is run by the BATC (British Amateur Television Club), it is service made freely available to all interested parties, please do not abuse this privilege.

Thank you
Post Reply
Posts: 13
Joined: Thu Apr 27, 2023 11:17 am

Portsdown & Adalm Pluto / Problems Connecting Using CAT5

Post by GM0SCA » Fri Jun 07, 2024 6:58 pm


This might be a bit lengthy but hopefully what I include helps...

I have a Portsdown 4 which is up to date with Software Version 202405300 and I can stream the test card or camera images to the BATC Streamer (though I've not got the audio figured out yet...!).

I have an Adalm Pluto Rev B and when connected to the Portsdown using USB, Portsdown shows both CPU's enabled, correct firmware (v0.31-4...dirty) and Pluto is expanded to AD9364 status.

With the Portsdown connected to the Pluto using USB, I can transmit on 437MHz and receive the signal across the shack on the MiniTiouner and its associated software. So - I think that all seems OK.

But... I really want to have the Pluto at the back of the dish which means using Ethernet. And this is where I come unstuck.

I know I need to go to the Portsdown Menu 3 / Pluto Config / and Set Pluto IP for Portsdown; and I know I need to edit the config.txt file on the Pluto. What I don't know is what to put in either. I have spent hours trawling through the excellent Forum pages and tried numerous combinations to no avail. I have tried using the RJ45 socket on the RPi4 and I have tried an RJ45 to micro USB adapter; I am using an external 5V supply to the Pluto.

The list below is a copy of part of the config.txt file on the Pluto. Can someone please put me out of my misery and point me in the right direction!? I don't know if it helps but my home network is 192.168.1.nnn.

hostname = pluto
ipaddr =
ipaddr_host =
netmask =

ssid_wlan =
pwd_wlan =
ipaddr_wlan =

ipaddr_eth =
netmask_eth =
gateway_eth =

With thanks

73 Simon GM0SCA - desperately trying to beat Rob M0DTS to be the first GM on the DATV Net!!

Posts: 320
Joined: Tue Sep 10, 2013 7:28 pm

Re: Portsdown & Adalm Pluto / Problems Connecting Using CAT5

Post by Basil » Thu Jun 13, 2024 7:48 pm

What USB to ethernet adapter are you using at the Pluto? They can be fickle things. I have no clear memory of the setting up of Portsdown 4 to a remote ethernet connected Pluto, but I did use that setup for a while, however my Portsdown 4 hasn't been out of its box in a long time.

I do recall the first cheap USB to Ethernet gizmo didn't work in that scenario and I bought a branded one (Plugable brand in my case), which immediately did.

I think Analog Devices cite the USB to Ethernet chipsets that they recommend. Somewhere on their hard to navigate site...

No idea if the above is of any help!

My Pluto is on line below the dish 24 hours a day, seven days a week. Once I got the teething problems sorted it is VERY rarely rebooted, it's probably been up and running undisturbed for months.

BTW if you use network scanner software can it see the USB to ethernet adapter on your network and what IP address has it got? I'm well outside my comfort zone with IP stuff but I saw your plea on the BT net earlier and felt you deserved some sort of a reply :)

If you get really desperate I'll pull the Portsdown out of hibernation and remind myself how I set it up.

Chris. 2E0ILY
Last edited by Basil on Tue Jun 18, 2024 5:13 am, edited 1 time in total.

Posts: 24
Joined: Tue Oct 18, 2022 10:30 am

Re: Portsdown & Adalm Pluto / Problems Connecting Using CAT5

Post by g3uis » Thu Jun 13, 2024 8:47 pm

I think Basil has nailed your problem. The USB to Ethernet adapter IP address is the one you need. That should be on your local subnet. The Pluto IP isn’t relevant in this context.


Posts: 147
Joined: Sun May 05, 2019 12:15 pm

Re: Portsdown & Adalm Pluto / Problems Connecting Using CAT5

Post by G4FKK » Thu Jun 13, 2024 9:14 pm

Hi Simon,

Like Basil, I had some issues using a USB to ethernet adapter - although I did get one working reliably after a couple of false starts. Now though, I use a Pi Zero as an adapter as described by Tom, ZR6TG, here...

https://www.zr6tg.co.za/2022/08/07/plut ... pberry-pi/

As far as the Portsdown goes, you need to go to Menu 3 and select "Pluto Config" then select "Set Pluto IP for Portsdown" and enter the IP address of your ethernet adapter (or Pi Zero if you go down Tom's route). You already have the correct firmware installed on your Pluto so, with any luck, it should all then just work :-)

If you also have Langstone installed on your PD4 then there's another button in Menu 3 labelled "Langstone Config" and in that menu you set the same IP address using the button labelled "Set Pluto IP for Langstone".

There's a piece of free software you can run on a PC called "Advanced IP Scanner" which should tell you the IP addresses of anything plugged into and running on your Local Area Network. That should let you know what your adapter's address is. You can download it from here...


Good luck and I hope to see you on the net soon.

73, Martin

Post Reply

Return to “Getting Started?”