Installation failed for the Langstone specific folders

Forum for discussion about the Langstone Microwave Transceiver that shares some features with the Portsdown. Wiki: https://wiki.microwavers.org.uk/Langstone_Project
Post Reply
Mark G6AHY
Posts: 2
Joined: Tue Oct 12, 2021 12:17 pm

Installation failed for the Langstone specific folders

Post by Mark G6AHY » Tue Oct 12, 2021 1:50 pm

Hi All

I have read through the previous threads on this issue that i can find and did not find anything similar so I thought a new thread would be better.

I am sure it is something daft but i have followed the installation instructions and tried two full and fresh installation, I am very new to Raspian or indeed Linux or any of the various derivatives and so my investigation skills are a bit limited so to save a few hours of trial and error i thought i would ask those who know for a pointer or two. When it attempts to start i get error messages saying it cannot find the files and from what i can see the Langstone directory is not being created and hence no files.

Many thanks

Regards

Mark


This is the error i can see when the installation script runs.

cc: error: /home/pi/Langstone/LangstoneGUI.c: No such file or directory
cc: error: /home/pi/Langstone/HW_Test.c: No such file or directory
cc: error: /home/pi/Langstone/Pluto_Test.c: No such file or directory

This is what i see in the PI directory


pi@raspberrypi:~ $ cd /home/pi
pi@raspberrypi:~ $ ls -la
total 32
drwxr-xr-x 3 pi pi 4096 Oct 12 12:43 .
drwxr-xr-x 3 root root 4096 May 7 15:42 ..
-rw------- 1 pi pi 298 Oct 12 12:46 .bash_history
-rw-r--r-- 1 pi pi 220 May 7 15:42 .bash_logout
-rw-r--r-- 1 pi pi 3523 May 7 15:42 .bashrc
drwx------ 3 pi pi 4096 Oct 12 12:18 .gnupg
-rwxr-xr-x 1 root root 3197 Oct 12 12:20 install.sh
-rw-r--r-- 1 pi pi 807 May 7 15:42 .profile

g4eml
Posts: 467
Joined: Thu Apr 26, 2018 9:36 am

Re: Installation failed for the Langstone specific folders

Post by g4eml » Wed Oct 13, 2021 12:53 pm

Hi Mark,

It looks like the installation failed for some reason. Internet connection problems can cause things like this. Retrying again a few hours or days later sometimes works. Also Raspberry Pi have a habit of making changes that cause downloads to fail.

I don’t have time to re-test the install at the moment, I will try to do that in the next day or so.

Colin G4EML

Mark G6AHY
Posts: 2
Joined: Tue Oct 12, 2021 12:17 pm

Re: Installation failed for the Langstone specific folders

Post by Mark G6AHY » Wed Oct 13, 2021 4:47 pm

Hi Colin

I think i have it sorted now thank you, a call with Dave G8GKQ managed to sort things out.

The first bit was the lack of installation of the Langstone files, this we are unsure why but after running the specific installation lines from the script it installed fine.

The second issue was due to me being new to the whole linux command line thing and after a few failed attempts with the initial installation script i ran them using Sudo and now know why i should not have :-)

Safe to say it now appears to work and i will start some testing and of course some more learning :-)

Many thanks for your response

73 <DE> Mark

g4eml
Posts: 467
Joined: Thu Apr 26, 2018 9:36 am

Re: Installation failed for the Langstone specific folders

Post by g4eml » Wed Oct 13, 2021 8:09 pm

Hi Mark,

That’s good news.
And thanks to Dave for your help.

Colin.

Post Reply

Return to “The Langstone Microwave Transceiver”