Pluto With Portsdown - Reliability Problems

Discussion about this major DATV Project. See https://wiki.batc.org.uk/The_Portsdown_Transmitter
Post Reply
G8GKQ
Site Admin
Posts: 1986
Joined: Sun Mar 22, 2009 1:21 pm

Pluto With Portsdown - Reliability Problems

Post by G8GKQ » Mon Jan 18, 2021 11:01 pm

I know that many Portsdown/Pluto users have been experiencing reliability problems recently. I have had similar problems today, for the first time since starting working with the Portsdown and the Pluto.

I currently have 2 Portsdown 4s with Plutos on my bench. The first, my usual Portsdown 4 development rig, has the Pluto soldered inside a home-made tinplate box which is bolted to the same chassis as the Raspberry Pi and the 7 inch Screen. I have never had any reliability problems with this Portsdown/Pluto equipment.

The second setup has a Pluto plugged into a Portsdown 4 by its supplied USB lead, but the Pluto is in its blue plastic case on the bench. It has been connected to my spectrum analyser and (through an attenuator) a Ryde receiver throughout the day. Every time that I disconnect or reconnect it, or disturb any related test equipment in the shack, this Pluto has gone off-line. I am sure that the well-known problem of earth loops between the USB connection and the RF connections is the culprit. These do not occur in my boxed unit, because the USB and RF paths are connected through the tinplate box.

I'll be trying the recommended grounding modification next to see if that cures the issue. Scroll down on this page to find details. https://www.f5uii.net/en/transmit-datv- ... lutodvb/4/

Dave, G8GKQ

g8lce
Posts: 183
Joined: Sun Dec 06, 2015 10:26 am

Re: Pluto With Portsdown - Reliability Problems

Post by g8lce » Thu Jan 21, 2021 12:11 am

I find the first bit of reliability problems are with the micro USB connector and if it wobbles about. It is slightly better with the minitiouner mini USB but the best USB connector on any Portsdown addon I have is the one on the minitiouner express I have just bought. Pity the DC connector uses a large centre pin. The USB connector on the limemini is OK but not very rigid onto the printed circuit.
I have had issues with the micro USB plugs on other equipment and the cure is usually to hold the plug up one way from where it would normally be so as the connectors make contact. Just a little force makes it work but then you have to find someway of holding it there! Not very reliable!! Changing the lead sometimes helps but for how long.
Hope the earthing arrangements work for you.

Have you changed the Xtal as in the link? When I started using Longstone in the Portsdown 4 I found the drift quite annoying.
Using the Pluto for 10GHz ( via 5th harmonic ) was easy and the second Portsdown to receive with LNB.

Martin G8LCE

User avatar
G1LPS Terry
Posts: 158
Joined: Mon Mar 10, 2008 10:33 pm

Re: Pluto With Portsdown - Reliability Problems

Post by G1LPS Terry » Thu Jan 21, 2021 11:48 am

Hi Dave my observations on the issue

Both my Pluto's don't have the earth mod.
I run them on LAN. Normally I don't use a Y cable to power the LAN dongle as you often see recommended on line. This plugs directly in the USB port and I power the Pluto on the power port. In this configuration I don't experience disconnections when switching other connected equipment such as test equipment or amplifiers. Connecting this way works very well for me.

Recently I used one of my LAN adapters on the GB3KM build so after a look around the shack found a y adapter and USB A LAN adapter and pressed these into service. I then started experiencing Pluto disconnections when power supplies to amplifiers connected to the Pluto were switched off.

So I ordered a LAN adapter that plugs directly into the Pluto as used before and applied power on the Pluto power connector.
With this method no disconnections. Swapping back to the Y adapter cable reintroduced issues.

I had read about the grounding modification but didn't apply it as Initially I had no issue.
Interested in your findings if you had time to try it.

Br Terry

Post Reply

Return to “The Portsdown Digital ATV System”