Portsdown 4 Update with LongMynd improvements

Discussion about this major DATV Project. See also https://wiki.batc.org.uk/The_Portsdown_Transmitter
G8GKQ
Site Admin
Posts: 1817
Joined: Sun Mar 22, 2009 1:21 pm

Portsdown 4 Update with LongMynd improvements

Post by G8GKQ » Sun Oct 18, 2020 2:58 pm

I have just released an update for the Portsdown 4 which includes the latest, most reliable, version of the LongMynd receive software, and also adds the "5th harmonic mode" to the Portsdown Pluto Signal Generator, extending its coverage (at very low power) to well above 10 GHz. The full list of notable changes:
  • LongMynd software now recovers from slow tuner VCO locks and does not freeze.
  • Pluto Signal Generator has a "5th harmonic mode" potentially providing a signal source up to 30 GHz.
  • The user's original Langstone Configuration file is restored after a Langstone update
  • Langstone stop command (on selection from Portsdown) has been removed to prevent the Langstone hanging during start.
I would encourage all Portsdown 4 users to perform this update, as there have been a number of new features added recently.

Dave, G8GKQ

radiogareth
Posts: 559
Joined: Wed Jan 06, 2016 9:46 am

Re: Portsdown 4 Update with LongMynd improvements

Post by radiogareth » Sun Oct 18, 2020 3:21 pm

Worked for me, great update :-)
Would modulation on the sig gen be a future possibility?
Thanks for all the work on this :-)

Gareth

F4DVK
Posts: 31
Joined: Mon Nov 27, 2017 6:24 pm

Re: Portsdown 4 Update with LongMynd improvements

Post by F4DVK » Fri Oct 23, 2020 6:46 pm

Hi Dave,

A friend just tried DVB-S FEC 7/8 with pluto, but it doesn't work. Do you have any idea of ​​the problem?

Thank you,
Stephane.

g0mjw
Posts: 1336
Joined: Sat Sep 20, 2014 9:15 am

Re: Portsdown 4 Update with LongMynd improvements

Post by g0mjw » Fri Oct 23, 2020 7:39 pm

DVB-S? Sounds like it might be for a repeater. At what bit rate? Pluto doesn't do high rates.

G8GKQ
Site Admin
Posts: 1817
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown 4 Update with LongMynd improvements

Post by G8GKQ » Fri Oct 23, 2020 8:50 pm

Hi Stephane

I have just reproduced the problem, but can't see why it does not work. DVB-S FEC 5/6 does not work either.

Maybe Evariste has some ideas? (I'm using Firm2101RC dated 5 February 2020 and simply feeding it rtmp). For 333kS FEC 7/8 the video bitrate is 345856, and the audio bitrate is 64k.

Dave

User avatar
M5TXJ
Posts: 196
Joined: Wed Jul 05, 2017 8:34 pm

Re: Portsdown 4 Update with LongMynd improvements

Post by M5TXJ » Mon Oct 26, 2020 10:39 am

Hi Dave, Stephane,

I can confirm the same results here. Not sure if it's any help in diagnosis as I don't know the setup you were using Dave, but, using a C920 for video feed the blue camera active light comes on then just fades away.

73 Dave

p.s. I found the Portsdown 4 talk on CAT20 very useful.
...are you sure I can't use a pair of 813's?... :shock:

KA5BBC
Posts: 133
Joined: Thu Jun 28, 2018 6:59 pm

Re: Portsdown 4 Update with LongMynd improvements

Post by KA5BBC » Mon Oct 26, 2020 7:14 pm

M5TXJ wrote:
Mon Oct 26, 2020 10:39 am
Using a C920 for video feed the blue camera active light comes on then just fades away.
I have the same problem on the Portsdown 4 until I realize that this was a matter of current getting to the camera. Once attached to an RPI safe powered hub with a good PSU the problem went away.
Andy, KA5BBC/MM0BQV

g0mjw
Posts: 1336
Joined: Sat Sep 20, 2014 9:15 am

Re: Portsdown 4 Update with LongMynd improvements

Post by g0mjw » Mon Oct 26, 2020 9:05 pm

With the update menu I am getting a can't connect to Github error - but the internet is OK and it can contact google. Can you remind me what to do to fix that? I can ping github so rather odd?

Edit - a manual ssh rpidatv/update.sh update is going ahead OK it seems.

G8GKQ
Site Admin
Posts: 1817
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown 4 Update with LongMynd improvements

Post by G8GKQ » Mon Oct 26, 2020 10:36 pm

Sounds like a temporary internet or DNS glitch Mike. Anyway, you can try again if you want - I've just pushed another update.

Dave

g0mjw
Posts: 1336
Joined: Sat Sep 20, 2014 9:15 am

Re: Portsdown 4 Update with LongMynd improvements

Post by g0mjw » Mon Oct 26, 2020 10:53 pm

No - just the same. Problem with the setup maybe?
20201026_224737.jpg
20201026_224737.jpg (107.43 KiB) Viewed 121 times

Post Reply

Return to “The Portsdown Digital ATV System”