4"Display

Forum for discussion about the Langstone Microwave Transceiver that shares some features with the Portsdown. Wiki: https://wiki.microwavers.org.uk/Langstone_Project
OE6EMF
Posts: 8
Joined: Mon Sep 28, 2020 8:16 pm

4"Display

Post by OE6EMF » Sun Oct 04, 2020 9:16 am

Hi Colin! I have been using your software successfully for two months with the 6 "display in connection with a loudspeaker microphone and an HMC8038 6GHz RF switch from analog devices! But with the 4" display you should please help me. The display runs but the PTT does not work with the same configuration as the 6 "display. So i2c is activated in the Raspberry software and checked with sudo i2c detect - y 11! Ports on the display are also correctly plugged in. Unfortunately, the combination is missing. .. No ptt with pull resistor or relay voltage for hmc8038 on my pins. Maybe you can please help me with my problem! LG Thomas
Last edited by OE6EMF on Mon Oct 05, 2020 4:43 pm, edited 3 times in total.

g4eml
Posts: 352
Joined: Thu Apr 26, 2018 9:36 am

Re: 4"Display

Post by g4eml » Sun Oct 04, 2020 11:13 am

Hello Thomas,

As you have found the normal Raspberry Pi GPIO cannot be used when using the Pimoroni Hyperpixel4 4" display.
You need to use an MCP23017 module attached to the Hyperpixel4 i2c port. wired up as detailed here

https://wiki.microwavers.org.uk/Langsto ... c_expander

The MCP23017 needs to be configured as device address 20 by grounding the A0, A1 and A2 pins. On some modules this is done by default, on others you may have to add jumpers.

You can check the device is recognised by using the command 'sudo i2cdetect -y 11'
You should see the following:-

Code: Select all

     
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- UU -- -- -- -- -- -- -- -- -- -- --
20: 20 -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

Device 20 is the MCP23017 module.
Device 14 is the touch screen controller in the 4" display.

If device 20 is present on bus 11 then it will be automatically detected and used by the Langstone program. PTT input is on PA0, Key input is on PA1, Tx Output is on PA7, Band select bits are on PB0-7.

If you are seeing the device but it is still not working then let me know and I will try to help some more.

73 Colin G4EML

OE6EMF
Posts: 8
Joined: Mon Sep 28, 2020 8:16 pm

Re: 4"Display

Post by OE6EMF » Sun Oct 04, 2020 7:17 pm

Hi Colin! Thanks for the reminder! :idea: Hardware configuration was still missing as you described! PTT and GHz switches work now perfectly! :lol: LG Thomas OE6EMF
Attachments
Screenshot_20201004_211650_com.android.gallery3d.jpg
Screenshot_20201004_211650_com.android.gallery3d.jpg (1.01 MiB) Viewed 983 times
Screenshot_20201004_211637_com.android.gallery3d.jpg
Screenshot_20201004_211637_com.android.gallery3d.jpg (859.4 KiB) Viewed 983 times
Screenshot_20201004_211624_com.android.gallery3d.jpg
Screenshot_20201004_211624_com.android.gallery3d.jpg (1.18 MiB) Viewed 983 times

g4eml
Posts: 352
Joined: Thu Apr 26, 2018 9:36 am

Re: 4"Display

Post by g4eml » Mon Oct 05, 2020 12:15 am

Glad you got it working.

I have added the extra instructions to the wiki.

73
Colin G4EML

OE6EMF
Posts: 8
Joined: Mon Sep 28, 2020 8:16 pm

Re: 4"Display

Post by OE6EMF » Wed Oct 07, 2020 7:26 pm

Hello Colin!
Very nice!
Thank you for your help!
Best regards, keep it up!
Thomas

OE6EMF
Posts: 8
Joined: Mon Sep 28, 2020 8:16 pm

Re: 4"Display

Post by OE6EMF » Sun Nov 08, 2020 9:39 pm

Soon!
73 de OE6EMF
Attachments
Screenshot_20201107_181751_com.android.gallery3d.jpg
Screenshot_20201107_181751_com.android.gallery3d.jpg (1.17 MiB) Viewed 678 times

OE6EMF
Posts: 8
Joined: Mon Sep 28, 2020 8:16 pm

Re: 4"Display

Post by OE6EMF » Sat Nov 14, 2020 8:49 pm

First pictures of the Langstone TRX backside!
73 de OE6EMF Thomas
Attachments
IMG_20201114_214053.jpg
IMG_20201114_214053.jpg (1.96 MiB) Viewed 581 times

OE6EMF
Posts: 8
Joined: Mon Sep 28, 2020 8:16 pm

Re: 4"Display

Post by OE6EMF » Wed Jan 20, 2021 5:59 pm

Good evening Colin for your information, the problem was with the display! Everything works perfectly with the new display, thank you!
Greetings from cold Austria!

OE6EMF
Posts: 8
Joined: Mon Sep 28, 2020 8:16 pm

Re: 4"Display

Post by OE6EMF » Sat Jan 23, 2021 9:36 pm

Now ready to use! ;)
73!
Attachments
IMG_20210123_222546.jpg
IMG_20210123_222546.jpg (1.79 MiB) Viewed 211 times
IMG_20210123_222633.jpg
IMG_20210123_222633.jpg (1.53 MiB) Viewed 211 times
IMG_20210123_222735.jpg
IMG_20210123_222735.jpg (1.71 MiB) Viewed 211 times

G4FKK
Posts: 82
Joined: Sun May 05, 2019 12:15 pm

Re: 4"Display

Post by G4FKK » Sun Jan 24, 2021 9:04 am

Very nice Thomas! Where did you get the panels made?

73, Martin - G4FKK

Post Reply

Return to “The Langstone Microwave Transceiver”