Portsdown2019 H264 mode will not work

Discussion about this major DATV Project. See also https://wiki.batc.org.uk/The_Portsdown_Transmitter
BG0AUB
Posts: 12
Joined: Sat Feb 16, 2019 8:16 pm

Portsdown2019 H264 mode will not work

Post by BG0AUB » Mon Jul 08, 2019 3:32 am

hello
I am BG0AUB. Recently I built portsdown2019, this is a great project.Easy to use DATV.I tested limesdr mini + portsdown2019 QO100 repeater.His work is very good.It's very convenient.But I find that if I set of DVB - S2 QPSK H264 mode.Limesdr mini did not produce the correct spectrum.If when the SR low, will produce a larger peak at the center of the frequency point.The SR is high, he what also have no output.I consulted another article about H264 don't work in the BBS posts, and repeatedly in different SD card to recompile the portsdown2019.The phenomenon still exists.
datv1.jpg
datv1.jpg (134.99 KiB) Viewed 1165 times
datv2.jpg
datv2.jpg (149.14 KiB) Viewed 1165 times
datv3.jpg
datv3.jpg (150.77 KiB) Viewed 1165 times

G8GKQ
Site Admin
Posts: 1287
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown2019 H264 mode will not work

Post by G8GKQ » Mon Jul 08, 2019 11:19 am

Hi

The report on your second picture shows that your LimeSDR is failing the LimeQuickTest. More details here: https://wiki.myriadrf.org/Testing_the_LimeSDR. So that is a LimeSDR problem, not a Portsdown problem. Some LimeSDRs fail this test (by a small tolerance) but still work perfectly.

What symbol rates, FECs and video sources are you having the problems that you report with? There are some modes that do not work at the moment. Please refer to the table here: viewtopic.php?f=103&t=6070#p19583

73

Dave

BG0AUB
Posts: 12
Joined: Sat Feb 16, 2019 8:16 pm

Re: Portsdown2019 H264 mode will not work

Post by BG0AUB » Mon Jul 08, 2019 11:58 am

hi Dave
Thanks for your reply. I will check according to the process you said.I found even Ugly mode.Raspberry's pin7 doesn't have any output.But in mpg2 mode, pin7 is output.Thanks again.
73
zhaofeng BG0AUB

BG0AUB
Posts: 12
Joined: Sat Feb 16, 2019 8:16 pm

Re: Portsdown2019 H264 mode will not work

Post by BG0AUB » Tue Jul 09, 2019 11:17 am

The loop test of limesdr using PC software still failed.It seems there is a limesdr problem.In Ugly mode.Should h264 be working?
微信图片_20190709191522.jpg
微信图片_20190709191522.jpg (183.4 KiB) Viewed 1024 times

BG0AUB
Posts: 12
Joined: Sat Feb 16, 2019 8:16 pm

Re: Portsdown2019 H264 mode will not work

Post by BG0AUB » Tue Jul 09, 2019 11:21 am

Limequicktest loop test prompt failed because tx_2-lna_w. Limesdr mini has only one TX interface.Tx1. All of the following pass the test.I don't know if everyone has this problem.Maybe I misunderstood

G8GKQ
Site Admin
Posts: 1287
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown2019 H264 mode will not work

Post by G8GKQ » Thu Jul 11, 2019 10:15 am

LimeQuickTest works on all the LimeSDR Minis that I have.

Dave

BG0AUB
Posts: 12
Joined: Sat Feb 16, 2019 8:16 pm

Re: Portsdown2019 H264 mode will not work

Post by BG0AUB » Thu Jul 11, 2019 10:27 am

Thank you for your reply.I will try to solve these problems...

BG0AUB
Posts: 12
Joined: Sat Feb 16, 2019 8:16 pm

Re: Portsdown2019 H264 mode will not work

Post by BG0AUB » Mon Jul 22, 2019 4:29 pm

I bought the new limesdr mini.You can pass the loop test.No errors were detected in Portsdown.But H264 still doesn't work.There is no normal spectrum output.I tried different combinations of parameters...
Attachments
微信图片_20190723002550.jpg
微信图片_20190723002550.jpg (83.54 KiB) Viewed 686 times
微信图片_20190723002544.jpg
微信图片_20190723002544.jpg (109.32 KiB) Viewed 686 times
微信图片_20190723002531.jpg
微信图片_20190723002531.jpg (113.07 KiB) Viewed 686 times
微信图片_20190723002508.jpg
微信图片_20190723002508.jpg (105.47 KiB) Viewed 686 times

G8GKQ
Site Admin
Posts: 1287
Joined: Sun Mar 22, 2009 1:21 pm

Re: Portsdown2019 H264 mode will not work

Post by G8GKQ » Mon Jul 22, 2019 4:52 pm

Hi

Please refer to this table. Only the settings in Green work properly: viewtopic.php?f=103&t=6070#p19583. Somke questions for you:

Does your Pi Cam show on the touchscreen during transmit?

Does Ugly mode (at 437 MHz - use Preset 4 to select) work?

Does MPEG-2 work?

Did you get any errors while you were building the SD Card (warnings are OK - errors could be a problem)?

Please try SR250 DVB-S2 FEC 3/4 with the Pi Cam and tell me what happens.

73

Dave, G8GKQ

BG0AUB
Posts: 12
Joined: Sat Feb 16, 2019 8:16 pm

Re: Portsdown2019 H264 mode will not work

Post by BG0AUB » Tue Jul 23, 2019 1:41 pm

Hi Dave
Thank you for your reply.Today I did some tests as you suggestedFirst configure the parameters according to the green section in the link.Using Pi CAM as signal source, no normal spectrum is output in H264 coding.There is also no PICAM preview on the LCD.Using Ugiy mode, h264 also does not output normal spectrum.If the mpg-2 encoding is used, all the above tests are normal output spectrum.As to whether there was an error when the software was compiled, I can only be sure that there was no error reported before the automatic restart.I'm not sure about the compilation process.But I did three separate compilations with three different sd CARDS.The results are consistent.The screen and spectrum displayed by LCD in Picam H264 are selected as accessories.
73
zhaofeng BG0AUB
Attachments
22.jpg
22.jpg (109.11 KiB) Viewed 611 times

Post Reply

Return to “The Portsdown Digital ATV System”