Pluto with DATV Express

Digital ATV - The latest generation, cutting edge ATV - Please discuss it all here.
Forum rules
This forum is run by the BATC (British Amateur Television Club), it is service made freely available to all interested parties, please do not abuse this privilege.

Thank you
G3YQC
Posts: 25
Joined: Mon May 06, 2019 6:42 pm

Re: Pluto with DATV Express

Post by G3YQC » Mon Jan 06, 2020 4:17 pm

Thanks very much for the replies guys, it has been most useful. I have just confirmed that my new Pluto is defective. A new unit arrived today and that works just as it should. I shall now try Evarist's firmware

Best 73, John

g8lce
Posts: 112
Joined: Sun Dec 06, 2015 10:26 am

Re: Pluto with DATV Express

Post by g8lce » Tue Jan 07, 2020 11:35 pm

Hi John,

Could you see if DATV Express still works with the new software as it did not with mine! As you probably know I have been having problems connecting via the network cable setup.
I have now got a solution which will take a diagram to explain in full but here is a brief description.
The video and audio start in vMix on the main computer. I can select various inputs and the video files can be in various formats/resolutions. The output of the computer is routed through an AMX 3155 which sends an HDMI output to an AMX 1100. This gets the video and audio onto the network and streams a UDP stream to port 7171 ( any port but not 7272 ). I then have the remote computer (a simple ex display driving device running Windows 10) running vMix and its input is the above stream and its output streaming to the Pluto ( connected via USB ) as per the network way of working I wanted to do.
Seems complicated but the output video at 333SR is now acceptable to me and similar to others on Oscar 100 that I thought good.
The benefits of this setup are:
a) vMix as a starting source is very good and can do most things I need.
b) the AMX 3155 is a very expensive video switcher and audio mixer equalizer and compressor and test signal generator that is now around on Ebay very cheap. It can do all sorts of adjustments to the video and audio including resampling to reduce the output resolution.
c) the AMX 1100 converts the HDMI output via a HDMI to DVI lead to a network stream (or two ) with various sample rates etc.
d) the remote computer connected via USB to the Pluto running vMix as a Stream in and Stream out to the connected Pluto gets the Pluto working. This allows the Pluto to be programmed to convert the audio from 64kbs to 32kbs which reduces the data to within limits. ( adding a ,32, in the streaming setup string )
I have tested the system locally and will be on Oscar 100 testing it in the next day or so. I have to be careful not to overload the power amp and blow another one up!!!!

Now for receiving I use yet another computer and Minitioune as this makes the audio easier to separate and stop any howl round which you do hear on some transmissions on Oscar 100

Martin G8LCE

G3YQC
Posts: 25
Joined: Mon May 06, 2019 6:42 pm

Re: Pluto with DATV Express

Post by G3YQC » Thu Jan 16, 2020 2:20 pm

Hi Martin,
I can confirm that the Pluto, with F5OEO firmware, does indeed work with DATV Express v1.26 taking the usual external output from vMix. Using a laptop I can of course also stream directly from vMix to the Pluto which also works well BUT:

I have just built a new desktop computer with i5 9th generation CPU and quite high spec motherboard, chipset, fast RAM and solid state drive, but no separate graphics card and, although the computer itself recognises the Pluto and duly displays the F5OEO screen, I cannot get DATV Express software to detect the Pluto and neither will vMix when I try to stream! I have checked and re-checked all the appropriate settings both in the software and Windows but can't get it to work. So why does it work on the laptop but not the Desktop? Any ideas anyone.

I am not well up on streaming matters Martin, all these boxes with numbers don't really mean much yet but I am trying to sort it out. I am a lone worker with no-one to ask around here.
Best 73

g0mjw
Posts: 1256
Joined: Sat Sep 20, 2014 9:15 am

Re: Pluto with DATV Express

Post by g0mjw » Thu Jan 16, 2020 5:34 pm

I am not sure why you are trying to use DATV Express with the latest Pluto firmware as it isn't really needed. However I verified it works fine for me so I suspect there may be either a driver incompatibility or a firewall block or an issue with Express settings, e.g. wrong IP address. You will need to provide more information to tell but the fact it works on a laptop but not a desktop makes me think its a driver or network problem specific to the desktop. Make sure you have not got your home wired network set to 192.168.2.xxx subnet as the PC might not know where to send stuff.

You say can't get VMIX to stream to the pluto. Can you stream to anywhere, e.g. from VMIX to BATC? (See Wiki for VMIX streaming to BATC if you don't already have this set up)

I think this is unlikely given the laptop works but exactly what version of the F5OEO firmware are you using? I am not sure the earlier one supported the USB UDP, It did support RTMP but the command format was extended. The web page the pluto displays when you access it via a web browser has instructions, if it does not have any instructions or the commands are different then maybe it's an old version.

PS - oh yes. The Pluto is plugged into the Desktop and it has got sufficient power ?

Mike

g8lce
Posts: 112
Joined: Sun Dec 06, 2015 10:26 am

Re: Pluto with DATV Express

Post by g8lce » Fri Jan 17, 2020 11:57 pm

I had a problem today with my Pluto connected to my Desktop computer!
I have just been converting a power amp for 2.4GHz and needed to feed some RF into it. As I connected the Pluto the computer made the USB Disconnected sound and the Pluto disappeared from the computer! When I disconnected the Pluto from the power amp the USB Connected sound played and the Pluto was back!! The PSU driving the power amp is earthed ( I will check for certain tomorrow) and the desktop is earthed but I measured some small voltage between the Pluto and the Power amp earth.
So that could be causing me some problems or pointing to other problems!
BUT
I have sorted out another problem I have been having. That is the Pluto not working with DATV Express after the new software was loaded.
This is all with a laptop:
I formatted the Pluto's disc space so there was nothing in it (I tried this by deleting everything there before and still had the problems). Then I copied pluto.frm (actually pluto(1).frm and changed it's name to pluto.frm after I copied it across) to the pluto disc space and ejected the pluto. After the 4 minute plus flashing time the pluto restarted and DATV Express works it!!
Next thing will be to see if the remote networking now works...
and if it works with DATV Express on my desktop....
I know there are other ways (and better?) to work with the new software but DATV Express is still useful.

Martin G8LCE

g0mjw
Posts: 1256
Joined: Sat Sep 20, 2014 9:15 am

Re: Pluto with DATV Express

Post by g0mjw » Sat Jan 18, 2020 8:53 am

Hi Martin

The problem with the Pluto and the power is well documented and there is a hardware mod to prevent it. It's to do with the way power is supplied and the small voltage difference is triggering that. Do a google search and it will come up.

The re-formatting probably wiped the config files and eliminated some bad settings. Glad it worked.

Mike

Edit - see Here https://wiki.analog.com/university/tool ... g/hardware

g8lce
Posts: 112
Joined: Sun Dec 06, 2015 10:26 am

Re: Pluto with DATV Express

Post by g8lce » Sat Jan 18, 2020 10:07 am

Thanks Mike,
I think that there might be hidden files as well that I wiped by doing a format.
Written it up as a new topic.
Martin G8LCE

G3YQC
Posts: 25
Joined: Mon May 06, 2019 6:42 pm

Re: Pluto with DATV Express

Post by G3YQC » Mon Jan 20, 2020 6:12 pm

Hi Guys. Just to say I have cracked the problem with the new computer not recognising Pluto. It was indeed a driver problem. I had (of course) carefully checked that the correct driver was installed and "working properly". Obviously not! In desperation I uninstalled the driver, downloaded it again from the internet and installed it, lo and behold it now works - no idea what was wrong!

No Mike I am not trying to use F5OEO/Pluto with Express, it was just an indication that neither that or vMix recognised the Pluto and therefore pointing to where the problem might be. Anyway I shall move forward with the RF driver now so that I can replace the existing Lime/Express setup with the new.

My thanks for all the help, especially to Mike who always has some advice to offer whenever I put a post on. It is much appreciated.

Best 73, John G3YQC

Post Reply

Return to “DATV - Digital ATV”