big carrier in the middle of my modulation

The place for discussion about the RPi add-on RB-TV modulator card developed by G4EWJ and supported by the BATC Shop
Post Reply
F6DZP
Posts: 156
Joined: Fri May 27, 2011 9:59 am
Location: Poitiers - France
Contact:

big carrier in the middle of my modulation

Post by F6DZP » Tue Jul 07, 2015 8:56 am

Hello,
I have started for the first time my Digithin this morning.
- Pidatv image 1.2.1
- raspberry model B

it seems to modulate well, but I have a big carrier remaining.
input is 437MHz . I try between -10 and -20 dBm, it changes nothing.
first test.jpg
first test.jpg (117.47 KiB) Viewed 1522 times
Have you an idea to fix this?
thanks

Jean-Pierre F6DZP

g8gtz
Posts: 833
Joined: Wed Apr 07, 2010 6:26 pm

Re: big carrier in the middle of my modulation

Post by g8gtz » Tue Jul 07, 2015 9:54 am

Hi jean Pierre

Looks like the digithin isn't actually getting the right data stream from the Rpi. With an LO of -20 DBm the output when correctly modulated should be 0dBm.

What's the LED doing? It should be flashing every second - if it's not that's the problem and you need to check you're running 333Ks and if you are playing a TS file it is recorded at right bit rate...



Noel

F6DZP
Posts: 156
Joined: Fri May 27, 2011 9:59 am
Location: Poitiers - France
Contact:

Re: big carrier in the middle of my modulation

Post by F6DZP » Tue Jul 07, 2015 10:21 am

I have a 20dB attenuator before my spectrum analyzer.
led flash every second.
All seems to work, but there is that high LO signal that remain..
I suppose I must check the level of IQ that go in the modulator, perhaps they are too low?

Jean-Pierre F6DZP

G4EWJ
Posts: 623
Joined: Wed Feb 17, 2010 10:11 am
Location: Wirral

Re: big carrier in the middle of my modulation

Post by G4EWJ » Tue Jul 07, 2015 11:04 am

Check the level of I and Q just after the analogue filters: junction of C17-R16 and junction of C20-R17.

The levels should be about 120mv pk-pk.

Hopefully it's something simple. I have also seen that pattern if the modulator is faulty. If it's the one I gave you in Portsmouth, I think that came from the Ebay batch from Israel.

Brian

F6DZP
Posts: 156
Joined: Fri May 27, 2011 9:59 am
Location: Poitiers - France
Contact:

Re: big carrier in the middle of my modulation

Post by F6DZP » Tue Jul 07, 2015 11:33 am

I have only 40 mv pk pk at C17-R16 junction.

Jean-Pierre

G4EWJ
Posts: 623
Joined: Wed Feb 17, 2010 10:11 am
Location: Wirral

Re: big carrier in the middle of my modulation

Post by G4EWJ » Tue Jul 07, 2015 12:53 pm

What values do you have for R21 and R25? They are 'select by test' to give about 120mv pk-pk. 1k seems to be about the required value.

Even that would not explain the very low level of the modulation, so it must be something else causing it.

Brian

F6DZP
Posts: 156
Joined: Fri May 27, 2011 9:59 am
Location: Poitiers - France
Contact:

Re: big carrier in the middle of my modulation

Post by F6DZP » Tue Jul 28, 2015 11:48 am

I have changed the modulator by a new one sent by Brian (thanks).
Now this problem is fixed.
R500_100mv_1MHz.JPG
R500_100mv_1MHz.JPG (114.06 KiB) Viewed 1303 times
when I receive on 437Mhz, max MER is 27dB.
Tutioune1600 digithin 437 SR333 MER27dB R500.jpg
Tutioune1600 digithin 437 SR333 MER27dB R500.jpg (476.22 KiB) Viewed 1303 times
using R21=390 ohms, 120mV I have now 29dB MER

Jean-Pierre F6DZP

Post Reply

Return to “DigiThin”