Pluto not connecting - help please...

Digital ATV - The latest generation, cutting edge ATV - Please discuss it all here.
Forum rules
This forum is run by the BATC (British Amateur Television Club), it is service made freely available to all interested parties, please do not abuse this privilege.

Thank you
G3YQC
Posts: 25
Joined: Mon May 06, 2019 6:42 pm

Pluto not connecting - help please...

Post by G3YQC » Sat Dec 28, 2019 2:45 pm

I recently bought an ADALM Pluto but after installation I have two problems:
1. I tried using it with SDR# using the instructions from rtl-sdr.com and installed the latest SDR# PlutoSDR plugin. I can select the Pluto from the SDR# list but it will not connect.
2. When I select Pluto in DATVExpress software (version 1.26) it cannot find the device. Also DATVExpress will not start if the Pluto is already plugged in. The software works fine with Lime Mini.

I have set up the Pluto using instructions listed in Pluto’s info.html file as follows:
1. Updated firmware to version 0.31
2. Installed USB driver: PlutoSDR-M2k-USB-Drivers.exe - v0.7
3. Installed libiio library from file: libiio-0.18.g4e22517-Windows-setup.exe
4. Performed the two tests specified using iio_info - both tests successful
5. Expanded the frequency range and carried out the verification test successfully
6. Enabled the second CPU core and carried out the verification test successfully
7. I can log in from a browser, Command prompt, or PuTTY using ip: 192.168.2.1
8. I can log in with PuTTY using the USB serial port
9. Tried several different USB cables – no change

I have searched forums and elsewhere extensively for help but can find nothing.
Can anyone suggest anything I have missed or should have done?

g0mjw
Posts: 1137
Joined: Sat Sep 20, 2014 9:15 am

Re: Pluto not connecting - help please...

Post by g0mjw » Sat Dec 28, 2019 2:55 pm

Perhaps a firewall issue?

g4eml
Posts: 210
Joined: Thu Apr 26, 2018 9:36 am

Re: Pluto not connecting - help please...

Post by g4eml » Sat Dec 28, 2019 7:07 pm

The Pluto is quite sensitive to power fluctuations. Noise or poor grounds can cause it to fail. Have you tried using a separate power supply plugged into the second USB connector?
I had to do this with mine before it worked reliably. Without it the Pluto would initially appear to work but failed as soon as it started to Rx or Tx.

G3YQC
Posts: 25
Joined: Mon May 06, 2019 6:42 pm

Re: Pluto not connecting - help please...

Post by G3YQC » Mon Dec 30, 2019 7:03 pm

Thanks guys for the suggestions. I have carefully tried them out but absolutely nothing I try makes any difference. I will probably conclude that there is something wrong with the Pluto.
Best 73 John

g8lce
Posts: 101
Joined: Sun Dec 06, 2015 10:26 am

Re: Pluto not connecting - help please...

Post by g8lce » Wed Jan 01, 2020 11:41 pm

I had been using a Pluto with DATV Express and it worked well. I loaded the new firmware ' Custom DATV Firmware for the Pluto ' and that worked too. Then I tried using the network access to the Pluto setting it's ip to fit in my system. I am sure it worked once but now I cannot get it to work via the network. I have tried reflashing, different network adapters (as in various articles) and many other things but I cannot get it to work. The computer sees it's network address but it is only a one way thing so I cannot control it. If I connect straight to the computer using a USB cable the networking works as expectected.
I tried DATV Express and that does not find the Pluto anymore!
Somewhere along the line I seem to have got the Pluto in a different mode.
One thing I liked about the new Pluto firmware is the ability to resample the 64kbit audio to 32kbit. I have a IP streamer that will only go down to 64kbit audio. On Oscar 100 I use the ip streamer to stream to a RPI and Portsdown but the 64kbit audio is too much data!! (I TX 333kbit/s) If I could get the Pluto to work over the lan then I would use it for Oscar 100 and my audio problems would also go.
I have checked and double checked the config settings for the pluto and the network configuration works when usb connection but not when network connection. The only thought I have not tested is, could it be the router? I have many other things going on on my network and the router has not been a problem with anything else.
If there is someone out there who recognises this problem? lets hope you know what I am doing wrong...

Martin G8LCE

g0mjw
Posts: 1137
Joined: Sat Sep 20, 2014 9:15 am

Re: Pluto not connecting - help please...

Post by g0mjw » Thu Jan 02, 2020 9:24 am

Unless you really understand networking and services it's likely to be difficult to diagnose without more tests.

You should be able to SSH into the Pluto but you don't mention having tried this. You should also be able to laccess the onboardweb server.

I assume this is wired and not Wifi.

What is the Pluto IP and Is it the same subnet as your computer?
How did it get this IP address? DHCP on the router? Don't try to set it manually unless you really know what you are doing.
How is the OTG network adaptor powered? This is critical. Insufficient power often causes intermittent confusing behaviour
Is there a firewall getting in the way? Microsoft have a high aptitude for causing problems.

You said the Pluto works via USB so I assume you can SSH into it when it is connected that way and you can see the web server and run RTSP and UDP to it?
If so, why not jut use it via USB? Is there a specific need to network?

Mike

PS - If all this sounds like a fortnight language to anyone then I am afraid there is a necessary learning curve.

g8lce
Posts: 101
Joined: Sun Dec 06, 2015 10:26 am

Re: Pluto not connecting - help please...

Post by g8lce » Fri Jan 03, 2020 8:37 am

Hi Mike,

Yes I have done all the above.
Using Advanced IP Scanner the Pluto shows up but without the > before the device when in network mode but with it in usb mode. This is a clue I am sure. I have 40+ devices on the network and this is the only thing giving me problems!
I will think about the > in the Advanced IP Scanner output. It does not appear on my Portsdown RPi but I can SSH to it. I will try SSH to the Pluto.

Thanks

Martin G8LCE

g8lce
Posts: 101
Joined: Sun Dec 06, 2015 10:26 am

Re: Pluto not connecting - help please...

Post by g8lce » Fri Jan 03, 2020 10:25 am

Here are some of my findings:

Pluto setup copied from pluto web server on usb connection

Version Information:

The various parts of the firmware all have their own unique versions as well:
Model Analog Devices PlutoSDR Rev.B (Z7010-AD9363A)
Serial 104400b839910012120017003fe4643e82
Build v0.31-4-g9ceb-dirty
Linux Linux pluto 4.14.0-g387d584d434e-dirty #14 SMP PREEMPT Sat Nov 16 23:07:09 CET 2019 armv7l GNU-Linux;1 core(s)
U-Boot U-Boot PlutoSDR v0.20-PlutoSDR-00043-gefdb9e8 (Dec 18 2017 - 18:25:09 +0100)
FPGA 2018_r2
Root FS v0.20-13868-gd8216-dirty
IIO Library version: 0.18 (git tag: v0.18)
Back to top

Standalone Applications:

Custom C/C++ applications can be created/compiled on a host with a Linaro GNU Compiler Collection (GCC) toolchain (with the appropriate flags), transferred over and run directly on the PlutoSDR.
GCC Compiler Target Triple arm-linux-gnueabihf
GCC version Linaro GCC 7.3-2018.04-rc3 7.3.1 20180314
Binutils version Linaro_Binutils- 2.29.1.20171214
SysRoot Latest SYSROOT
Back to top

Build Settings:

There are many settings which are set as part of the build configuration, and can not be changed without rebuilding the firmware.
Username: root
Password: analog
Back to top

Configuration Settings:

On the root file system, there are configuration settings that can modify the default configuration, they currently are:
Hostname pluto
IP Address (PlutoSDR) 192.168.123.100
IP Address (HOST) 192.168.123.254
Netmask 255.255.255.0
MAC Address (PlutoSDR) 00:05:f7:3b:76:20
MAC Address (HOST) 00:e0:22:4d:cb:51
Back to top

Wi-Fi Update
SSID
WPA-PSK Passphrase ********
IP Address
Back to top

Wired Ethernet using a USB Ethernet adapter. Update
IP Address
Netmask 255.255.255.0
------------------------------------------------------------------------------------------------
Here is the list of the Pluto from Advanced IP Scanner:

pluto 192.168.123.100 Analog Devices, Inc. 00:05:F7:3B:76:20

and I can SSH to it in the usb connected position.

Now I cannot see it when connected using the network adapter (and I have the ones others have used and another type ). I am using separate power from a RPi psu.
My IP addresses are 192.168.123.xxx and the router is 192.168.123.254 .

The reason I want to use the network connection is so I can remote the Pluto to near the Linear and Dish.

Any more ideas?

Martin G8LCE

g0mjw
Posts: 1137
Joined: Sat Sep 20, 2014 9:15 am

Re: Pluto not connecting - help please...

Post by g0mjw » Fri Jan 03, 2020 11:48 am

How is the network adaptor powered?

G8GKQ
Site Admin
Posts: 1595
Joined: Sun Mar 22, 2009 1:21 pm

Re: Pluto not connecting - help please...

Post by G8GKQ » Fri Jan 03, 2020 6:43 pm

Martin

Not sure that I can help you, but I can stop you going down a rabbit-hole. The Portsdown does not connect to a Pluto whether it is working or not. The button is there for future expansion capacity only. And that task has not reached the top of the to-do list....

Dave, G8GKQ

Post Reply

Return to “DATV - Digital ATV”