Use of the NVIDIA Jetson Nano for DATV

Digital ATV - The latest generation, cutting edge ATV - Please discuss it all here.
Forum rules
This forum is run by the BATC (British Amateur Television Club), it is service made freely available to all interested parties, please do not abuse this privilege.

Thank you
M0SKM
Posts: 292
Joined: Sun Jul 13, 2014 3:15 pm

Re: Use of the NVIDIA Jetson Nano for DATV

Post by M0SKM » Mon Jul 01, 2019 2:01 pm

Hello Tim,

My Nano backup image is uploaded if you still want to try it. There's a download link in an email sent to the address I found on QRZ.

73 Steve

G4WIM
Posts: 294
Joined: Thu Jan 29, 2015 8:36 pm

Re: Use of the NVIDIA Jetson Nano for DATV

Post by G4WIM » Mon Jul 01, 2019 2:46 pm

Thanks again Steve,

I'll let you know how it works out.

Regards Tim

G4WIM
Posts: 294
Joined: Thu Jan 29, 2015 8:36 pm

Re: Use of the NVIDIA Jetson Nano for DATV

Post by G4WIM » Mon Jul 01, 2019 6:08 pm

Hi Steve,

no joy so far I'm afraid but something odd going on

With my rpi and jetson images I have control of the lime via the nano but no video - as usual with my system. But my RPI works fine with the lime plugged into it directly ie I can at least send a testcard at 333k DVBS etc.

With your image the jetson works great when running one of your configured scripts with picam plugged into Jetson, but when I try my RPI to control it - it doesn't want to respond to any commands not even shut down.

This despite entering the username and password you gave me and the buttons turning blue indicating the rpi can detect it ok.

I have all the network connections plugged into on known good router Draytek 2680.

Proving to be quite a nasty problem !

EDIT - working for a few minutes then stopped

So I went back to my original jetson image with everything plugged into one router and it works again. No idea why as I tried this earlier but with no joy.
However one observation is that the LKV is flooding my gigabit network and making ssh unresponsive when try to drill down into the scripts from a PC.

So it could be that the lkv is blocking traffic - I had noticed on our Sonos audio system that the TV sound was suffering from dropped packets until I turned the lkv off.

I wonder if it's possible to have the lkv on its own sub net to avoid potentially packet loss problems.

g0mjw
Posts: 1168
Joined: Sat Sep 20, 2014 9:15 am

Re: Use of the NVIDIA Jetson Nano for DATV

Post by g0mjw » Mon Jul 01, 2019 9:05 pm

Did you remember the LKV firmware web interface? This allows you to set the streaming rate. That is assuming you are using the firmware as outlined in the blog here https://blog.danman.eu/new-version-of-l ... r-lkv373a/ - you need to scroll down the comments quite a bit.

Mike

M0SKM
Posts: 292
Joined: Sun Jul 13, 2014 3:15 pm

Re: Use of the NVIDIA Jetson Nano for DATV

Post by M0SKM » Mon Jul 01, 2019 9:24 pm

Hi Tim,

Just seen your update but I already sent the link to the image you requested.

One of the routers I tested couldn't handle the data rate and fell over after five minutes; that was a Thompson TG589vac v2. I'm using an early BT router now and it works fine.

Looks like you're getting there.

Regards
Steve

G4WIM
Posts: 294
Joined: Thu Jan 29, 2015 8:36 pm

Re: Use of the NVIDIA Jetson Nano for DATV

Post by G4WIM » Mon Jul 01, 2019 9:32 pm

Hi Mike, Steve

I'm thinking my network can't handle the lkv stream consistently for whatever reason - it may also be blocking ip commands getting from the rpi to the nano.

So I'll definately look at reducing the data rate from the lkv.

Going to have a sniff with wireshark tomorrow to see if that sheds any light.

I'm downloading Steve's rpi image as well - can't believe I haven't got to the bottom of this but I will do ......

Regards Tim

G8GKQ
Site Admin
Posts: 1649
Joined: Sun Mar 22, 2009 1:21 pm

Re: Use of the NVIDIA Jetson Nano for DATV

Post by G8GKQ » Mon Jul 01, 2019 9:59 pm

Tim

I had really bad network problems with one of my routers - whenever I connected the LKV373A with its broadcast UDP the network would cease to function. I changed the router and then everything worked perfectly. I now run the LKV373A and Jetson on a separate network from the rest of the house.

Dave

G4WIM
Posts: 294
Joined: Thu Jan 29, 2015 8:36 pm

Re: Use of the NVIDIA Jetson Nano for DATV

Post by G4WIM » Tue Jul 02, 2019 7:23 am

Hi Dave,

yes that's the conclusion I've come to after it started to work for a while then stopped, plus our network around the house is pretty busy anyway with 55 devices and about 30 of them active at anyone time.

Surprised that a 100Mb LKV could cause such trouble on a 1Gb network though.

So I'll set up a dedicated network for the rpi, nano, lkv and a pc to keep an eye on things. I've got a couple of old BT routers so we'll see how that goes.

I'll report back how things go .

Regards Tim

G4WIM
Posts: 294
Joined: Thu Jan 29, 2015 8:36 pm

Re: Use of the NVIDIA Jetson Nano for DATV

Post by G4WIM » Tue Jul 02, 2019 3:53 pm

I've been doing some experiments using the LKV with a range of routers, hubs and switches and the conclusion is that the LKV is fussy about the type of switch.

BT Home hub 3 and 4 sometimes work ok and initially I thought I'd fixed it - but then both of them decided they were't going to issue a DHCP address to the LKV so I moved over to an old Sky router which seems to work at least for now.

The question I have is how can the reliability of the LKV connection be improved ?

Perhaps as Mike suggests by reducing the video bit rate - I currently have both FHD set to 15000 and HD set to 6000. I have set the video output resolution for both FHD and HD to HD so I expect I'm running at 6000 ?
Many thanks to Steve for his assistance with the rpi and jetson images !

Regards Tim

G4WIM
Posts: 294
Joined: Thu Jan 29, 2015 8:36 pm

Re: Use of the NVIDIA Jetson Nano for DATV

Post by G4WIM » Wed Jul 03, 2019 3:04 pm

Update

I've managed to get the LKV consistently working on my network as I can see its stream on VLC and wireshark - I'm mirroring the port which has the Jetson attached to it so I know the data is getting there.

However the Jetson frequently ignores the LKV traffic which according to VLC is running at 1728x1080 at 29.97 fps H264.

Out of interest what are others seeing signal wise when monitoring the feed with VLC ?

Also any ideas as to why the Jetson ignores the feed ?

FYI the jetson to like the camcorder better when fed to the LKV rather than the PC even though both appear to get encoded ok by the LKV.

The IP and ports are set correctly.

Regards Tim

Post Reply

Return to “DATV - Digital ATV”