There is light

Discussions about using the CaribouLite Hat for ATV and Microwave
Post Reply
SkyVision
Posts: 48
Joined: Fri Jan 24, 2020 1:51 pm

There is light

Post by SkyVision » Wed Jun 14, 2023 1:16 am

Looks like we've had a stay of execution
https://www.crowdsupply.com/cariboulabs ... w-features
Sounds upbeat, although they've hit a few speed bumps

Roger VK5YYY

g8lce
Posts: 321
Joined: Sun Dec 06, 2015 10:26 am

Re: There is light

Post by g8lce » Wed Jun 14, 2023 3:33 pm

So I have tried to load this new update.
Firstly I have found that with the old version using Dragon OS 30 that once I shut it down I could not get it to load the system again!
I loaded the new Dragon OS 31 to try the system again and went through the process of setting the Cariboulite up from https://github.com/cariboulabs/cariboulite . When you try this and get to the
install.sh
it should be
./install.sh
I think.
Note: the user will be requested to enter their password during the installation process. ( dragon )
Then you need to refer to https://github.com/cariboulabs/cariboulite/issues/94 for the config.txt configuration. ie.
-----------------------------------------------------
Next we need to set up SPI and i2c

sudo nano /boot/firmware/config.txt

find this section and make it look like this......

[all]
# Enable the audio output, I2C and SPI interfaces on the GPIO header. As these
# parameters related to the base device-tree they must appear *before* any
# other dtoverlay= specification
dtparam=audio=on
dtparam=i2c_arm=off
dtparam=spi=off
dtparam=i2c_vc=on

Now hit CTRL+x and then y then the ENTER key now reboot the Pi
------------------------------------------------------

I then tried to run the radio with no luck!
Then I ran
sudo sdrpp --server
and that started to run the server but stopped with errors!

That is as far as I got BUT when I switched off and on again at least the device booted up.

Any one else had any luck?

Martin G8LCE

dc1op
Posts: 26
Joined: Sat Jul 27, 2019 3:35 pm

Re: There is light

Post by dc1op » Thu Aug 10, 2023 5:07 pm

Hi all

got caribou working. The sollution to the general problem was already published in https://github.com/cariboulabs/cariboulite/issues/94, here a fork from konimaru was used. Meanwhile some bugs were remedied by cariboulabs as the 'issues' reports in cariboulabs/caribou github pages say. A correct cloning is also described in the directory cariboulite/README.md a f t e r cloning from https://github.com/cariboulabs/cariboulite page. The README file, which shows up when calling this page is faulty.

Took the following course of actions:

Set up the testrig:

Raspi3B/7"rpi display/Dragon OS 31 for the CaribouLite
Raspi4/display/Dragon OS 31 to control CaribouLite for reception using sdr++
Laptop running VNC viewer to reduce the number of keyboards and mice on the bench
all connected via LAN
next without caribou mounted on the Raspi3 changed the config.txt file as follows:

#dtparam=spi=on (outcommented)
#dtparam=i2c_arm=on (outcommented)
dtparam=i2c_vc=on (added)
dtoverlay=spi1-3cs (added)

Save mods to config.txt
sudo reboot

next made the directory /projects and started git clone

git clone https://github.com/cariboulabs/cariboulite.git (=now extended with .git)

next ./install.sh

The installation went went smoothly and at the end it said something like "all ok", no warnings etc.

next sudo shutdown

After that had finished and power was disconnected, plugged in caribou on the Raspi3 and powered Raspi3 again.

next sudo SoapySDRUtil --find -->It found the caribou HiF and S1G channels

next sudo sdrpp --server -->It run (with some Alsa-errors in between) but finished reporting 'listening on 0.0.0.0 5259'

next starting sdr++ on Raspi4, selecting 'sdr++ server' in the field SOURCE, inputting Raspi3's IP and 5259, pushed'Connect'. Now in the field 'Source [REMOTE]' SoapySDR and CariboiLite showed up. Hit 'Play' and the SA window becomes active. Choose a station to listen to.

next Checked the repeatability of starting Raspi3 with caribou: in SDR++ hit 'Disconnect' which caused the Soapy Server to stop, then run

sudo shutdown

next Starting Raspi3 and after sudoing SoapySDRUtil --find and sdrpp --server --> all was working again.

Finally my advice to cariboulabs:please keep your documentation duly updated to avoid ideling.

dc1op Hubertus

SkyVision
Posts: 48
Joined: Fri Jan 24, 2020 1:51 pm

Re: There is light

Post by SkyVision » Wed Nov 29, 2023 10:58 am

The Cariboulite guy has updated a bunch of stuff on Github a couple of days ago
https://github.com/cariboulabs/cariboulite
Cheers Roger

Post Reply

Return to “CaribouLite RPi Hat”