Longmynd not loaded - Solved

Discussions about the new Ryde "Set-top Box" Style Digital ATV Receiver
Post Reply
G1LWX
Posts: 58
Joined: Sun Mar 27, 2011 11:10 pm

Longmynd not loaded - Solved

Post by G1LWX » Fri Jul 17, 2020 2:14 pm

HI
Started to build the Ryde project this morning.

Raspberry pi 4 4Gb.
Minitiouner.
Hdmi to vga convertor.

Sd card built up as per wiki.

After loading the software and rebooting "Longmynd not loaded" flashes up for one second
then goes back to prompt.
I have rebuilt the sd card twice but still having problems

Mike G1LWX
Last edited by G1LWX on Fri Jul 17, 2020 4:21 pm, edited 1 time in total.

MW0RUD
Posts: 35
Joined: Fri Apr 24, 2020 3:09 pm

Re: Longmynd not loaded

Post by MW0RUD » Fri Jul 17, 2020 3:17 pm

Hi Mike,
Can you ssh in and run this for me and post the output?

Code: Select all

cd /home/pi/ryde
python3 -m rydeplayer /home/pi/ryde/config.yaml
Tim

G1LWX
Posts: 58
Joined: Sun Mar 27, 2011 11:10 pm

Re: Longmynd not loaded

Post by G1LWX » Fri Jul 17, 2020 5:09 pm

Hi Tim here you go

login as: pi
pi@192.168.8.188's password:
Linux raspberrypi 4.19.118-v7l+ #1311 SMP Mon Apr 27 14:26:42 BST 2020 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Jul 17 17:04:25 2020
pi@raspberrypi:~ $ cd /home/pi/ryde
pi@raspberrypi:~/ryde $ python3 -m rydeplayer /home/pi/ryde/config.yaml
pygame 1.9.4.post1
Hello from the pygame community. https://www.pygame.org/contribute.html
Namespace(**{'Config File': '/home/pi/ryde/config.yaml'})
/home/pi/ryde
Handset has no button definitions
Handset has no button definitions
Frequency: 741500
Symbol Rate: 1500
Polarity: PolarityEnum.NONE
Port: inPortEnum.TOP
[None]
Traceback (most recent call last):
File "/usr/lib/python3.7/runpy.py", line 193, in _run_module_as_main
"__main__", mod_spec)
File "/usr/lib/python3.7/runpy.py", line 85, in _run_code
exec(code, run_globals)
File "/home/pi/ryde/rydeplayer/__main__.py", line 20, in <module>
player.run()
File "/home/pi/ryde/rydeplayer/player.py", line 327, in run
newplayer = player('config.yaml')
File "/home/pi/ryde/rydeplayer/player.py", line 237, in __init__
self.vlcStartup()
File "/home/pi/ryde/rydeplayer/player.py", line 319, in vlcStartup
self.vlcPlayer = self.vlcInstance.media_player_new()
AttributeError: 'NoneType' object has no attribute 'media_player_new'
pi@raspberrypi:~/ryde $

MW0RUD
Posts: 35
Joined: Fri Apr 24, 2020 3:09 pm

Re: Longmynd not loaded

Post by MW0RUD » Fri Jul 17, 2020 5:22 pm

Hi Mike,
Looks like something might have gone wrong during the install as it doesn't looks like VLC is installed. Can you try doing

Code: Select all

sudo apt-get install vlc
Tim

G1LWX
Posts: 58
Joined: Sun Mar 27, 2011 11:10 pm

Re: Longmynd not loaded

Post by G1LWX » Fri Jul 17, 2020 5:51 pm

OK
Now instead of flashing on for a second I am now getting the red screen with "Longmynd not loaded" all the time.

I have just noticed that it is showing an under voltage so that may explain things in the download.

G8GKQ
Site Admin
Posts: 1820
Joined: Sun Mar 22, 2009 1:21 pm

Re: Longmynd not loaded

Post by G8GKQ » Fri Jul 17, 2020 8:16 pm

Mike

I would suggest sorting out the power supply and then rebuilding the SD Card from scratch. Generally easier than troubleshooting a partial install.

Dave

G1LWX
Posts: 58
Joined: Sun Mar 27, 2011 11:10 pm

Re: Longmynd not loaded

Post by G1LWX » Sat Jul 18, 2020 8:26 am

Ok Dave/Tim
Sorting out a more robust psu today then will try another rebuild.
Never had a problem before building cards, psu must have been borderline.
Will report back.

Mike G1LWX

G1LWX
Posts: 58
Joined: Sun Mar 27, 2011 11:10 pm

Re: Longmynd not loaded

Post by G1LWX » Tue Jul 21, 2020 9:50 pm

Update
New 10A psu and rebuilt sd card all now ok.

Post Reply

Return to “The Ryde Digital ATV Receiver”