Ryde software 403 forbidden

Discussions about the Ryde "Set-top Box" Style Digital ATV Receiver. See https://wiki.batc.org.uk/Ryde_Receiver
G8GKQ
Site Admin
Posts: 2137
Joined: Sun Mar 22, 2009 1:21 pm

Re: Ryde software 403 forbidden

Post by G8GKQ » Fri May 21, 2021 7:25 pm

Richard

These are an incoherent set of problems, so the next thing that I would check is your power supply. Please measure the supply voltage on the GPIO pins of the Raspberry Pi - it should be between 5.0 and 5.2 V.

There also seems to be some sort of network problem (the line 66 "Address already in use"). Please try booting without any network connected; it may be that you have a conflict on your local network.

Dave

richardG4AOJ
Posts: 14
Joined: Tue Feb 14, 2017 4:29 pm

Re: Ryde software 403 forbidden

Post by richardG4AOJ » Fri May 21, 2021 7:52 pm

Dave
Thanks
I will persevere and thanks again for taking the time to help me
Richard

richardG4AOJ
Posts: 14
Joined: Tue Feb 14, 2017 4:29 pm

Re: Ryde software 403 forbidden

Post by richardG4AOJ » Mon May 31, 2021 2:01 pm

Dave

I have a new upgraded power supply and a completely new install (using the latest version). I can get a picture/sound on composite video and it decodes transmissions ok even though it says "Long Mynd not loaded". I still cannot get HDMI on either monitor or tv.

The code you asked me to run some time ago now gives the results attached.

Once again I appreciate your time and and your help.

73
Richard
Attachments
Screenshot 2021-05-31 at 14.52.07.png
Screenshot 2021-05-31 at 14.52.07.png (197.12 KiB) Viewed 603 times
Screenshot 2021-05-31 at 14.54.23.png
Screenshot 2021-05-31 at 14.54.23.png (882.19 KiB) Viewed 603 times

radiogareth
Posts: 723
Joined: Wed Jan 06, 2016 9:46 am

Re: Ryde software 403 forbidden

Post by radiogareth » Mon May 31, 2021 4:14 pm

May or may nor be relevant, but I had HDMI die on my Ryde Pi a couple of months ago. Sent it back for a replacement in the end. Tried everything Dave suggested and what the WWW had to offer. Supplier tested it, agreed and eventually sent me another new unit which has been fine.
Gareth

richardG4AOJ
Posts: 14
Joined: Tue Feb 14, 2017 4:29 pm

Re: Ryde software 403 forbidden

Post by richardG4AOJ » Tue Jun 01, 2021 9:51 am

Gareth

Thank you. I have tried a different Pi (I had one that was serving another function) to no avail.

I am not however giving up. I may purchase another Pi, as they are quite useful.

Regards
Richard

MW0RUD
Posts: 66
Joined: Fri Apr 24, 2020 3:09 pm

Re: Ryde software 403 forbidden

Post by MW0RUD » Wed Jun 02, 2021 10:44 am

Hi Richard,
I have 2 ideas that should help us make some progress:
  1. Can you confirm if you are using the HDMI port closest to the USB port?
  2. Can you make sure you stop ryde from the console menu and wait a few minutes before trying to start it manually and post the output? The network error is likely unrelated but is masking your actual issue.

    Code: Select all

    cd /home/pi/ryde
    python3 -m rydeplayer /home/pi/ryde/config.yaml
Tim

richardG4AOJ
Posts: 14
Joined: Tue Feb 14, 2017 4:29 pm

Re: Ryde software 403 forbidden

Post by richardG4AOJ » Sun Jun 06, 2021 10:31 am

Tim

Thanks for this. I have been a bit busy this week and the Ryde has been put to one side. I may get a chance to have another crack in the next few days

73


Richard

Post Reply

Return to “The Ryde Digital ATV Receiver”