Page 3 of 5

Re: Langstone Update 28/05/20

Posted: Thu Jun 04, 2020 5:38 pm
by G4FKK
Hi Colin,

Not sure if you can help but this afternoon my Langstone stopped working. I'd had a couple of 4m QSOs earlier and then left the Langstone on receive while I did some other work in the shack. The audio stopped first, closely followed by the waterfall and the GUI was non-responsive to screen touches or mouse input.

I used puTTY and I was able to log in as usual. I then CD'd to Langstone and typed ./stop. Portsdown then started up and, as far as I could tell, was working normally - I only did a couple of quick tests including using the stream viewer. I shut down the Pi from the Portsdown menu and cycled the power. Langstone came up with sound and waterfall but after a few (4 maybe), seconds conked out again.

I carried out a few more shutdowns/powercycles but all with the same result.

Next I went back in via puTTY and typed ps -ax. This seemed to indicated that all three programs were running but, on further inspection, seemed to show that was the only one actually clocking up any run time. I killed the programs as per your Debugging Notes and started them again. Same result; works for a few seconds and then stops.

I also tried updating from github but, again, same result when booting up. Swapping the sound card made no difference either.

My next plan is to start again from scratch but I'll leave things as they are in case there are any other tests you'd like me to try?

I'm running on a 2GB Pi 4. There's 1.5GB free and only around 3GB of the 32GB SD card used. The swap memory is ((MB with 0% used.

73, Martin - G4FKK

Re: Langstone Update 28/05/20

Posted: Thu Jun 04, 2020 5:40 pm
by G4FKK
That should say 99MB - doh!

Re: Langstone Update 28/05/20

Posted: Thu Jun 04, 2020 5:49 pm
by G4FKK
Forgot to add: I tested the Pluto on the PC running SDR Console - all ok, Similarly both soundcards ok on another Pi 4.

Re: Langstone Update 28/05/20

Posted: Thu Jun 04, 2020 8:37 pm
by oe6rke
hello all,

can confirm this issue. had it first after updating the Software via update. after that no waterfall and stopping Audio Right 5 sec from start, no reaction via touch.
Did Restart with a clean Image.
prepareded all first with update, upgrade, dist-upgrade and installed like the given sequence form here.

Did the first test according Troubleshooting with no issue but behaviour as described.
Then i fetched a clean instance via git and kicked in ./build with same result.

As lastest Resort i tried the build with portsdown, but all the same.

i guess some lib of the update on os Level changed the mouse or keypad Driver since console logon via Network is working perfect.
syslog and Messages log are not given a reason for this stuff. to sort out Hardware i've using two sdcards and also did a Display test on a full buster with correct touch behaviour.

as like as the other om i'm using a pi4 2 meg Version. used the versions until the todays update for two weeks without issues on unchanged Hardware..

hope the reason could be found since i've now clue how to gain back Control on the device,

br Robert, 73 de oe6rke

update after editing:
i tried a local copy of the Langstone Code i took an week ago with sam results. so in my opinion something linked into or updated by raspi.
tried to install the stuff without updating, but no luck. the os did'nt even start..:(
Portsdown A27 is working (build today with reponsive gui). so kinda mouse Driver possibly..

if i can support with logs pse let me know

Re: Langstone Update 28/05/20

Posted: Thu Jun 04, 2020 10:27 pm
by G4FKK
Hi Robert,

Interesting to hear you're also experiencing the same problem. I've just been chatting to Chris, G4SDG, on QO100 and he's suffering exactly the same effects too. I was beginning to think something had let out some magic smoke on my Pi but it does sound as if it's a system update that's upsetting the Langstone.

For what it's worth, I get the following message when I restart the GUI following the Debugging Notes...

Warning: The blks2.selector block is deprecated.
gr::log :INFO: audio source - Audio sink arch: alsa
len(audio_taps) = 231

Right - time for bed. Goodnight all,

73, Martin - G4FKK

Re: Langstone Update 28/05/20

Posted: Thu Jun 04, 2020 10:28 pm
by G4FKK
Oh, and I forgot to add that I rebuilt a new SD card from scratch with the same results.

Re: Langstone Update 28/05/20

Posted: Fri Jun 05, 2020 8:16 am
by G8GKQ
Yes, there have been some major changes to the Raspbian operating system over the last week. They have broken some of the Portsdown features as well.

Please be patient while Colin and I develop fixes for both Portsdown and Langstone, We have other priorities and committments as well.

Dave, G8GKQ

Re: Langstone Update 28/05/20

Posted: Fri Jun 05, 2020 8:39 am
by G8GKQ
So, in the meantime, please do not update your Langstones or Portsdown A27s - you'll break them. New builds are not possible either.


Re: Langstone Update 28/05/20

Posted: Fri Jun 05, 2020 9:17 am
by g4eml
I have not made any changes to the Langstone code for a while now so, as a Dave says, it must be down to a system update. I will have a look later today and see if I can reproduce and identify the problem.


Re: Langstone Update 28/05/20

Posted: Fri Jun 05, 2020 10:57 am
by G4FKK
Thanks Dave and Colin,

I know you're busy so very happy to wait for your expert eyes to do their stuff :)

Just a quick query though; does the Pi update by itself if it's connected to t'internet? I ask because I haven't done any Pi updates for at least a couple of weeks and my Langstone was working perfectly happily for several days when it suddenly decided to stop entertaining me.

73, Martin - G4FKK