Langstone Discussion Forum

Forum for discussion about the Langstone Microwave Transceiver that shares some features with the Portsdown. Wiki: https://wiki.microwavers.org.uk/Langstone_Project
g0mjw
Posts: 1747
Joined: Sat Sep 20, 2014 9:15 am

Re: Langstone Discussion Forum

Post by g0mjw » Wed Sep 30, 2020 7:24 am

I wonder if it's the PSU. Can you drive it with a proper 5V power supply to the GPIO 5V pin?

Mike

g8lce
Posts: 229
Joined: Sun Dec 06, 2015 10:26 am

Re: Langstone Discussion Forum

Post by g8lce » Wed Sep 30, 2020 9:38 am

I have found the problem! and it is a bit of a surprise.
I tried a seperate PSU -- no different
I updated all the software - no different
I connected the Pluto straight to th Raspberry Pi USB ( not through the powered USB Hub )
and it worked!!!!!

I say it again - IT WORKED!!!

So the next question is why? It is connected to the USB 3 on the RPi but the hub is USB 3.

The USB 3 hub works well with Portsdown 4.

So other findings:
Works from Portsdown 4 Langstone menu as well. Takes a little while to switch.

Tried the SD card in a SD card reader and that works. ( Once the SD memory card has been setup to work in the RPi,s SD card slot you can remove it and use it from a SD card reader plugged into a USB slot. Works for Portsdown 4 and Langstone but only once programmed )
This could allow people to use a Portsdown 4 or Langstone SD in USB card reader as two different systems.

Martin G8LCE

g4eml
Posts: 470
Joined: Thu Apr 26, 2018 9:36 am

Re: Langstone Discussion Forum

Post by g4eml » Wed Sep 30, 2020 9:57 am

I don’t think anyone has ever tried tried running the Pluto via a hub on the Pi, you are probably the first! The Pluto is not a simple USB device, it actually gets installed by the operating system as if it’s is a network device, so it may be that drivers can’t handle being connected through a hub. Or alternatively it might just be a power supply issue. As has been mentioned before the Pluto seems to be very fussy about power.

Switching back and forth between Portsdown and Langstone can take a while because Portsdown issues a rebooot command to the Pluto, so you have to wait until it finishes booting.

Being able to boot the Pi from a USB card reader seems to be a recent addition to the OS. I believe it will also boot from a a USB hard disk or SSD.

G8AGN
Posts: 34
Joined: Mon Mar 05, 2018 1:41 pm

Re: Langstone Discussion Forum

Post by G8AGN » Tue Oct 06, 2020 4:22 pm

Colin

would it be easy to add an additional sub-menu in the SET menu to allow a choice of display format, e.g.

(a) spectrum and waterfall (as at present)
(b) only waterfall
(c) only spectrum ?

In the case of (c), this would enable a bit more vertical detail on the spectrum display.

73
Barry, G8AGN

g4eml
Posts: 470
Joined: Thu Apr 26, 2018 9:36 am

Re: Langstone Discussion Forum

Post by g4eml » Tue Oct 06, 2020 4:57 pm

It would be possible, but not simple, and I don’t think that it would achieve much. The spectrum display would be bigger but it wouldn’t show much more detail.

crocky
Posts: 2
Joined: Sat Oct 10, 2020 2:52 am

Re: Langstone Discussion Forum

Post by crocky » Sat Oct 10, 2020 9:32 am

Well I loaded it twice to be sure it was not something I had done, just got the start up screen with a few squares with text written in them. No response other than that.

After doing a fair bit of reading here I have ordered the correct sound card, the one I had was not a good fit, should take a little over a week to arrive (eBay).

Pi4 4Gb, Extra cooling on the CPU. Pluto wide band.

Thanks for the great write-up and some incentive to try!

73, Bob
VK3CDE
73, Bob VK3CDE

w0iy
Posts: 27
Joined: Sat Jul 04, 2020 2:38 am

freq expansion from terminal?

Post by w0iy » Sat Oct 10, 2020 5:29 pm

Is it possible to do the Pluto freq expansion from the command Line? I can't find u-boot or screen cmds.

Tnx w0iy

G8GKQ
Site Admin
Posts: 2290
Joined: Sun Mar 22, 2009 1:21 pm

Re: Langstone Discussion Forum

Post by G8GKQ » Sat Oct 10, 2020 8:12 pm

Yes

Log in to the Pluto, as described here https://wiki.analog.com/university/tool ... s/firmware

and then

Code: Select all

# fw_setenv attr_name compatible
# fw_setenv attr_val ad9364
# reboot
as described here. https://wiki.analog.com/university/tool ... ustomizing

Dave

w0iy
Posts: 27
Joined: Sat Jul 04, 2020 2:38 am

Re: Langstone Discussion Forum

Post by w0iy » Sun Oct 11, 2020 6:17 pm

I'm now using Putty on my win box to access the Pluto. Logged in successfully.
Current version of fw=0.30
Downloaded and tried to install 0.32 from github

https://wiki.analog.com/university/tool ... s/firmware <-- says to copy both m2k.frm and pluto.frm, however the 0.32 zip does NOT contain a m2k.*

I went ahead and copied pluto.frm and did the Eject to update. It appears to have worked (watching LEDs blink). Now when I run "iio_attr -a -C fw_version" I get the following:


# #
# # iio_attr -a -C fw_version
# Multiple contexts found. Please select one using --uri:
-sh: Multiple: not found
# 0: (cf-ad9361-dds-core-lpc, ad9361-phy, cf-ad9361-lpc, xadc, adm1177 o
n Analog Devices PlutoSDR Rev.B (Z7010/AD9363)) [local:]
-sh: syntax error: unexpected word (expecting ")")
# 1: 192.168.2.1 (Analog Devices PlutoSDR Rev.B (Z7010-AD9363A)), serial
=1044730a199700061e001400272b7cdd9e [ip:pluto.local]
-sh: syntax error: unexpected "("
# #

Installed Pluto on pi. Pi comes up and I get the "light blue screen of hope" (Langstone Xcvr Loading..) but nothing more. It hangs.

Hope I haven't gotten things mixed versions of something???

Barry w0iy

g4eml
Posts: 470
Joined: Thu Apr 26, 2018 9:36 am

Re: Langstone Discussion Forum

Post by g4eml » Sun Oct 11, 2020 9:04 pm

I have never tried using the v0.32 firmware on the Pluto, so I can't comment.
If I can get the time I will try it over then next day or so.
In the meantime I suggest that you could try loading v0.31 which is known to work OK.

See my new post regarding updates to the Langstone which should help diagnose some of the more common hardware issues.

Colin G4EML

Post Reply

Return to “The Langstone Microwave Transceiver”