MiniTioune Decode issues

Discussion about the MiniTiouner board and the MiniTiouner Digital ATV Receive Software. See also http://www.vivadatv.org/index.php
Post Reply
G4uvz
Posts: 88
Joined: Sat Dec 09, 2017 10:30 am

MiniTioune Decode issues

Post by G4uvz » Mon Feb 12, 2018 8:44 am

I receive a really good signal from GB3ZZ with an MER of 18+ Sometimes on switch on this results in an instant picture. However over half the time I have to try and wake up the decoding! Sometimes Autopid helps but normally it requires selecting H264 or H265 and then back to Mpeg2 when the picture appears. I thought that I had sorted the issue by powering up the Mini before opening the program but again, sometimes it works, sometimes it doesn't! I am running V.6d and get the same results on a couple of Windows 10 laptops. Is this something which I have to accept or is there a work around?
Adrian

G4uvz
Posts: 88
Joined: Sat Dec 09, 2017 10:30 am

Re: MiniTioune Decode issues

Post by G4uvz » Mon Feb 12, 2018 2:13 pm

Looking back ...I see I asked this question a while back! Do we think that the latest software will make any difference??

G4uvz
Posts: 88
Joined: Sat Dec 09, 2017 10:30 am

Re: MiniTioune Decode issues

Post by G4uvz » Wed Feb 14, 2018 10:12 pm

Well I tied the latest software, and it was significantly worse on locking up usual all the greens and good MER but no picture, in spite of all the usual mpeg 2 264 265 switching?
Is no one else having this issue???

G8GKQ
Site Admin
Posts: 975
Joined: Sun Mar 22, 2009 1:21 pm

Re: MiniTioune Decode issues

Post by G8GKQ » Thu Feb 15, 2018 10:15 pm

Hi Adrian

Your question raises more questions than answers:

1. What is the spec of the (best) Computers that you are using?

2. What USB lead (design/length?)

3. USB2 or USB3 socket?

4. Have you checked with a spectrum analyser (or FreqShow on the Portsdown) to see if there are any interfering signals that could be causing the problem? You need to go at least twice the symbol rate either side.

5. Does it work any better if you turn the MiniTioune UDP output on, and view the pictures on VLC?

6. Is the lack of picture the only thing that changes between showing a picture and not showing a picture?

7. A video of the problem occurring might help the community judge if the behaviour is typical.

8. Does ZZ use standard PIDs?

The MiniTiouner MUST be powered up before opening MiniTioune.

Dave

G4uvz
Posts: 88
Joined: Sat Dec 09, 2017 10:30 am

Re: MiniTioune Decode issues

Post by G4uvz » Fri Feb 16, 2018 4:00 pm

HP Spec.PNG
HP Spec.PNG (15.86 KiB) Viewed 925 times
Thanks Dave..I will try and answer some of the questions!

Laptops are Intel Core 15 spec is attached

USB lead is .5 M but have tried others and problem is lead independent
Not sure about USB flavour I would guess that it is the older system as laptop 3 years old
No sign of any adjacent signals

I am yet to master the mysteries of the UDP output and VLC
I am thinking that it is an Mpeg issue as I don't have the problem rxing H265 but this is on 2M with an SR of 333
I will take some pics to illustrate the ..no picture screen but ZZ sends standard 256 257 and 512 513 on their channel 2

See attached sequence of pictures...as you see sometimes the STATION buttons are populated with the ZZ info other times not ...I thought I had cracked it by deliberately selecting H265 before selecting input B which I use for 23cms...within seconds Mpeg 2 button automatically switched and picture appeared! ..quit program connected and reconnected 12volts to Mini and tried the same again .......NO PICTURE!
Don't seem tp be able to upload pics..will try in separate message
Attachments
P1090184.jpg
P1090184.jpg (738.73 KiB) Viewed 925 times

G4uvz
Posts: 88
Joined: Sat Dec 09, 2017 10:30 am

Re: MiniTioune Decode issues

Post by G4uvz » Fri Feb 16, 2018 4:02 pm

More Pics
Attachments
P1090183.jpg
P1090183.jpg (524.44 KiB) Viewed 925 times
P1090182.jpg
P1090182.jpg (681.53 KiB) Viewed 925 times
P1090181.jpg
P1090181.jpg (852.45 KiB) Viewed 925 times
P1090180.jpg
P1090180.jpg (644.73 KiB) Viewed 925 times
P1090185.jpg
P1090185.jpg (756.83 KiB) Viewed 925 times

F6DZP
Posts: 163
Joined: Fri May 27, 2011 9:59 am

Re: MiniTioune Decode issues

Post by F6DZP » Sat Feb 17, 2018 6:01 am

Hello,

yes it is difficult to give quickly a definitive answer.
Sure your PC is powerful enough for this job
I use a Notebook with the same CPU, I can say that, when I lock to a signal, 99% of time I see the video without doing anything.

I suppose that you have first done all the tests with "TestMyMiniTiouner" and "CheckMinitiouneDriverAndFilters" and that result is good.

when you are well locked(= all leds are green),
-a part of the software starts to get the TS from the USB channel, sometimes, on some PC it doesn't always work and on the Minitioune version 0.7 there is way to know it : looking at the "bytes received" number that must be growing(under TS Status or at its right on the V06d).
- when TS is received from the USB channel a second part of the software try to find the DVB tables ( nb of channels , PIDs and codec associated)
it waits some seconds to find the DVB tables and sometimes cannot see all the information during this period so you must write yourself the PIDs or select them with the station button.
- then the TS is sent to a Windows process called a "graph" that will decode and display the video if we indicate to it the good PIDs and codec to use.
Sometimes the graph has some remaining data in its buffer or is in a situation that makes it not starting well, so, by clicking "H264" and going back to "Mpeg2" we force the graph to stop, change the codec and start again in the good way.
If you use the UDP to send the TS to VLC and you see that VLC always decodes the video, your problem is with the graph, We will have to look at the components your PC windows is using, (there are some windows components that do not work well with some graphic card chip/driver, and there are different solutions to force Windows to change the component used).

The last question is about the TS you are receiving, it is composed of 2 channels. I have never tested Minitioune with a 2 channels TS, only with one channel in a DATV signal or many ( 8 to 12) channels receiving a public broadcast satellite transponder.
Perhaps there is a specific situation in this 2 channels Ts that I have not well thought?
The best way to know it : Could you send me 10 or 15 sec of this TS recorded with Minitioune ? (f6dzp at yahoo.fr)
( use a dropbox if it is too large for your mailbox or upload it to vivadatv forum). Thanks.

Jean-Pierre F6DZP

Post Reply

Return to “The MiniTiouner and MiniTioune Digital Receive Software”