Minitoune v2 problem

Discussion about the MiniTiouner board and the MiniTiouner Digital ATV Receive Software. See also
Posts: 5
Joined: Sun Nov 12, 2017 12:18 am

Minitoune v2 problem

Post by G4GHD » Mon Nov 20, 2017 3:30 pm

On initial testing with "CheckMiniTiouneDriverAndFilters_V0_3a.exe", all checked out fine except for the NIM and Demodulator detection.
Error message shown was "Write_register function failure".

I assumed that there was a problem with the connections to the Serit, no solder bridges seen, so simply resoldered them in case any pads top-side weren't soldered properly.

Upon testing this time however, it reported "FT2232H has bad device B parameters, use FTprog to reprogram it."
I'm guessing here that I should've removed the module before doing the resoldering and I've either damaged or erased the module?

Any help with this will be appreciated.

Posts: 33
Joined: Thu Dec 08, 2016 10:17 am

Re: Minitoune v2 problem

Post by vk5bd » Tue Nov 21, 2017 1:59 am


Unless you still had power on the device when you were soldering, I would think it is unlikely that you would have caused damage, unless it was a static related issue.

Here is a link to the programming of the FT2232H device, it is from a while ago but would think it is still relevant to the current Minitiouner project

Hope this helps


Posts: 5
Joined: Sun Nov 12, 2017 12:18 am

Re: Minitoune v2 problem

Post by G4GHD » Tue Nov 21, 2017 3:53 pm

No power on the device when soldering of course, so I guess it was just caused by static leakage.

Module reprogammed and all is working fine now, thanks.

Posts: 16
Joined: Mon Sep 05, 2016 4:15 pm

Re: Minitoune v2 problem

Post by nix1296 » Thu Dec 28, 2017 8:40 pm

I will appreciate help in my problem with the Minitiouner V2
I've been fighting for over a week now, with the new V2 with Serit 4335 tuner.
Once all installed following the instructions in Windows 7 rigorously, running all the tests without any errors ... all green leds, no error message, resulting in a perfect screen, but NO VIDEO. It appears only in the center of the image space "No video or bad codec / PID"
The SW I have tested with the 0.6d and 0.7b versions, with the same result.
I have also tried it with another Windows XP computer, with the same result.
I have uninstalled and reinstalled it several times: same result.
One precision: The test signal is from a Digilite with PID video 33 and Audio 49
Could this be?
So far I have been working with Tutioune 3200 always working perfect.
Any suggestions would be welcome.
Thank you
Magi -EA3UM-

Posts: 16
Joined: Mon Sep 05, 2016 4:15 pm

Re: Minitoune v2 problem

Post by nix1296 » Fri Dec 29, 2017 2:19 pm

More data:
I notice that on pin 34 of the tuner FTS4334 ... no 4335, (TS2 clock out) there is no signal, only confusing noise.
I think there can be two causes:
Or there is a fault in the tuner,
Or do not receive anything from the FTDI2332
I'll try to reprogram it
Can someone suggest something to me?
Thank you

Magi -EA3UM-

Posts: 819
Joined: Wed Apr 07, 2010 6:26 pm

Re: Minitoune v2 problem

Post by g8gtz » Fri Dec 29, 2017 4:04 pm

Hi Magi,

Does the test program have successful video decode like this:

If not, you may not have the video codec pack installed. I suggest you follow the step by step instructions on the BATC wiki page here.

I would do this first before programming the USB module.

Let us know how you get on.

Noel G8GTZ

Posts: 38
Joined: Wed Aug 02, 2017 7:32 am

Re: Minitoune v2 problem

Post by G1BVI » Fri Dec 29, 2017 7:19 pm

I have the same problem on two lap tops
both running windows 7
if you record the stream can you play it back on vlc player.

I got it working on a 3rd laptop.

Still do not know why it does not work on the W7 m/c but I think it is something to do with the install................. winxp.exe not running properly on my machines


Posts: 16
Joined: Mon Sep 05, 2016 4:15 pm

Re: Minitoune v2 problem

Post by nix1296 » Fri Dec 29, 2017 9:31 pm

Dear friends
Thanks for your response and recommendations, but I think that something else happens here !!
I have known the operation of the Toutioune system for two years, both with the tecnotrend 3200 S2 card and with the first version of the Minitioune.
Here something else happens!
I have reprogrammed the FT2232 module several times and I have reviewed all the memorized parameters, and they are correct according to the instructions.
I pass all the tests: TestMyMinitiouner_1.4b and CheckMinitiouneDriverAnd Filters: v_04, with 0 errors and all the green leds.
I am in the version Minitioune V2 with SW v_07b .. Win7 and also with another computer with XP.
The tuner is a Serit FTS4334.
All connected and with signal generated by the Digilite SR4000:
Carrier Lock 100%, Timing Lock 100%, Power RF 40 dBm, MER 20, Viterbi err and Vber 0. ..5 green leds, TS err 0.
No error messages Everything perfect ... Result: "No Video or bad Codec / PID"
4 perfect points in the constellation.
I have verified on another computer the signal of the Digilite with Tutioune 3200 S2 and it reproduces it perfectly.
I have also tested with satellite signal 10758 MHz, SR22000, = Exactly identical results ... always "No video or bad codec / PID".
Distrusting the hardware, I have even tried to check the signals of the output TS of the tuner with an oscilloscope, and as far as I know, they seem good to me, although in this I am not sure.
I do not know what to look at anymore.
I know it is very difficult to make diagnoses, when they tell you that everything is perfect.
But I do not find anything wrong.
Something is missing.
Thanks for your help.

Magi -EA3UM-

Posts: 416
Joined: Sat Sep 20, 2014 9:15 am

Re: Minitoune v2 problem

Post by g0mjw » Fri Dec 29, 2017 10:31 pm

Are you getting any data through? If so record it and check it with VLC.


Posts: 16
Joined: Mon Sep 05, 2016 4:15 pm

Re: Minitoune v2 problem

Post by nix1296 » Fri Dec 29, 2017 10:44 pm

Yes. I understand that when the Minitioune screen shows me that it is receiving a signal and there is no indication of any failure, I understand that I am receiving data.

I have set the recording switch to ON, but the VLC does not play anything, playing the recorded file.

I suppose this should indicate something, but I do not know what is due.
What would be the next step?

We already have something!

Thanks, Mike

Magi -EA3UM-

Post Reply

Return to “The MiniTiouner and MiniTioune Digital Receive Software”