OLED Display for Minitiouner V2 with FTS4334L

Discussion about the MiniTiouner board and the MiniTiouner Digital ATV Receive Software. See also http://www.vivadatv.org/index.php
radiogareth
Posts: 151
Joined: Wed Jan 06, 2016 9:46 am

Re: OLED Display for Minitiouner V2 with FTS4334L

Post by radiogareth » Mon Nov 20, 2017 7:50 pm

I'll keep both hands in my pockets then. A nice addition though which makes the magic box look even more so.

G4FRE
Posts: 58
Joined: Fri May 26, 2017 6:57 am

Think carefully when mounting OLED Display for Minitiouner V2 with FTS4334L

Post by G4FRE » Wed Jan 10, 2018 12:00 am

Think very carefully when mounting the OLED display on the front panel of the recommended box. The module needs to be mounted as high as possible on the front panel distancing it from the PCB. I put mine centralish, because it looked prettier. It would not mount on the RHS as the regulators got in the way. So i flipped over the front panel and tried to mount it on the LHS, but the PCB got in the way. In the end i nibbled the pcb (the bit with the acknowledgements) to clear the module as shown below

The other thing I learnt, when reprogramming the usb module was , when you think you have reprogrammed the module in FT-PROG, exit the software, restart FT_PROG and reread the module to ensure it now identifies as a minitioune pro module. On my first attempt It did not change due to misinterpreting how FT_PROG worked

Dave
g4fre
Attachments
oled_mount.jpg
oled_mount.jpg (149.89 KiB) Viewed 1012 times

g0mjw
Posts: 597
Joined: Sat Sep 20, 2014 9:15 am

Re: OLED Display for Minitiouner V2 with FTS4334L

Post by g0mjw » Wed Jan 10, 2018 6:12 pm

I should have mentioned this, I have also done the same. You need to put it as high as possible as Dave noted and avoid the regulators. This was never part of the design, but an alternative is to use the longer version of the same case design. Then there is plenty of room. There is a photo of mine earlier in the OLED thread, it could have done with being a little higher.

Mike

PS - it looks to me that if you were to rotate your panel 180 degrees and turn around the OLED to its not upside down, it would fit. Finally, be very careful with the mounting to not press on the glass, it will shatter very easily.

radiogareth
Posts: 151
Joined: Wed Jan 06, 2016 9:46 am

Re: OLED Display for Minitiouner V2 with FTS4334L

Post by radiogareth » Thu Aug 16, 2018 12:05 pm

So I've got round to fitting one of these display modules now that MT v0.8 is installed and running. I've altered the config file as per the info in the PDF and saved it. (OLED=yes and digole=14 as its the small unit). As it picks up my callsign I assume that I've managed to correctly save the file ;)
Nothing on the display, doesn't even light up. Tried a second unit (also new) same thing. I have Gnd, V+ (from J2) and SCL and SDA correctly connected. Do I need to change the address on the oled module or something? Its currently on the left hand bridge 0X78, the empty RHS address being 0X7A?
Don't believe two new modules, even from China, are duff. What am I missing?


*UPDATE* Just tested one of the modules on an arduino and it works fine??

*Second update, just re-read the pdf, Digole seems to relate to a different type of screen so I have returned that to 0. Still nowt?

Thanks

Gareth

g0mjw
Posts: 597
Joined: Sat Sep 20, 2014 9:15 am

Re: OLED Display for Minitiouner V2 with FTS4334L

Post by g0mjw » Thu Aug 16, 2018 12:49 pm

I have had no trouble and have:
OLED=yes
Digole=no

Possible options - you need to change that address or perhaps you bought something different. What shape are the mounting holes?

Mike

radiogareth
Posts: 151
Joined: Wed Jan 06, 2016 9:46 am

Re: OLED Display for Minitiouner V2 with FTS4334L

Post by radiogareth » Thu Aug 16, 2018 2:18 pm

Hmm, well its identical to the unit shown in the second picture page 1 of this thread, blue pcb. All the units I have (4) have the same address set by a 4K7 sm resistor across the LHS address select terminals. I'd guess that the I2C address is buried in the main MT software.
Mystified....
Did a bit of web digging, suggest that 10K pull-ups should be used on one of the devices. Tried that (they may well already exist on the board thinking about it, for the other I2C devices) no change. Yet ALL the displays work on a 'stock' arduino display routine for this display.

The "CheckMT driver and filter" software routine says:
"
USB driver version: 2.12.28
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
I2C initialisation
----------------------------------------------------------------------
I2C controler INIT OK
OK MPSSE is empty
Init MPSSE I2C done!
"

so I2C seems to be alive and well.

*Update*, yes it is, both data lines alive and well as seen on my scope, but still no-show.
2018-08-16 15.59.41.jpg
2018-08-16 15.59.41.jpg (555.96 KiB) Viewed 614 times
shows the address resistor in the LHS top corner. Maybe that's it?

Gareth

G1BVI
Posts: 107
Joined: Wed Aug 02, 2017 7:32 am

Re: OLED Display for Minitiouner V2 with FTS4334L

Post by G1BVI » Thu Aug 16, 2018 4:16 pm

Can anyone recommend and give a part # for an OLED module that they have managed to squeeze into the original box?
Thanks and 73

Nick

radiogareth
Posts: 151
Joined: Wed Jan 06, 2016 9:46 am

Re: OLED Display for Minitiouner V2 with FTS4334L

Post by radiogareth » Thu Aug 16, 2018 4:28 pm

I believe they are 'generic' (Chinese copies) and if you search for these "0.96" I2C IIC Serial 128X64 White OLED LCD LED Display Module for Arduino UK" on eBay there are lots. However, as per my questions above, they work fine with my arduino but won't with my MT v0.8 so far. As to proper branded units, I doubt they actually exist....
Gareth

G1BVI
Posts: 107
Joined: Wed Aug 02, 2017 7:32 am

Re: OLED Display for Minitiouner V2 with FTS4334L

Post by G1BVI » Thu Aug 16, 2018 5:16 pm

Thanks Gareth
Placed an order and hoping you solve this soon so I know what to do :)

73

Nick

g0mjw
Posts: 597
Joined: Sat Sep 20, 2014 9:15 am

Re: OLED Display for Minitiouner V2 with FTS4334L

Post by g0mjw » Thu Aug 16, 2018 5:35 pm

radiogareth wrote:
Thu Aug 16, 2018 2:18 pm


*Update*, yes it is, both data lines alive and well as seen on my scope, but still no-show. 2018-08-16 15.59.41.jpg shows the address resistor in the LHS top corner. Maybe that's it?

Gareth
All seems OK. Suggest you try the other address. You must have checked the supply though you didn't say.
P1030158.jpg
P1030158.jpg (1.18 MiB) Viewed 594 times

Post Reply

Return to “The MiniTiouner and MiniTioune Digital Receive Software”