No usb device - Help me -

Discussion about the MiniTiouner board and the MiniTiouner Digital ATV Receive Software. See also http://www.vivadatv.org/index.php
Post Reply
iw2hxw
Posts: 7
Joined: Wed Aug 14, 2019 7:46 pm

No usb device - Help me -

Post by iw2hxw » Wed Aug 14, 2019 7:59 pm

Hi everyone, I think I have a problem with the FT2232H USB module that after working properly for about a week suddenly when the minitiouner starts does not recognize the USB port with the error code no usb device. I tried to replace the usb cable, to reinstall the drivers to restart the pc, to no avail. I proceeded to reprogram the USB module but FT_Prog cannot find the device. To program the module, do you need to remove it from the connectors and connect the USB cable, or do you have to insert jumpers? I hope the FT2232H module has not been damaged. Who helps me out of courtesy? Thanks Vincenzo IW2HXW

g8gtz
Posts: 1154
Joined: Wed Apr 07, 2010 6:26 pm

Re: No usb device - Help me -

Post by g8gtz » Thu Aug 15, 2019 12:15 pm

Hi Vincenzo

Does Windows make the dah, dah, dah system noise when you plug the USB in?

If not try plugging the hardware in to another PC (with 12v PSU connected to MiniTiouner but no s/w installed) and see if you get the noise - if not you have a hardware problem.

You can program the module in the standard hardware - you do not have to remove it.

73
Noel - G8GTZ

iw2hxw
Posts: 7
Joined: Wed Aug 14, 2019 7:46 pm

Re: No usb device - Help me -

Post by iw2hxw » Thu Aug 15, 2019 2:37 pm

Thanks Noel for having responded to my help.
The module does not work with another PC and when I connect the USB cable I do not receive the noise from the PC that indicates that it has detected hardware. I also changed the usb cable, to no avail. I carried out the voltage measurements at pins CN2.1 / CN2.3 / CN2.5, CN2-11 / CN2-21, CN3-12 / CN3-22 but I find about 1.5 volts instead of 3.3, volts. I deduce that this is the stabilizer stage inside the module. I think I need to replace the ft2232h module because it's damaged. the 5 volt voltage that takes from the pc usb to the CN3-1 / CN3.3 pins is stable at about 5 volts. what do you think ? 73 de Vincenzo IW2HXW

g8gtz
Posts: 1154
Joined: Wed Apr 07, 2010 6:26 pm

Re: No usb device - Help me -

Post by g8gtz » Thu Aug 15, 2019 3:35 pm

Hi

I think you should check the 3.3v regulator before changing the module and if that is fine, then a new module is probably required.

https://wiki.batc.org.uk/images/6/6d/SERIF.pdf

Was it bought from the BATC shop and if so how long have you had it?

73

Noel

iw2hxw
Posts: 7
Joined: Wed Aug 14, 2019 7:46 pm

Re: No usb device - Help me -

Post by iw2hxw » Thu Aug 15, 2019 4:15 pm

Hello,
the voltages on the base module are all regular, including the 3.3-volt one. , while the 3.3 volt voltage output from the USB module is not as regular as I said above. I don't want any electrostatic discharge to have damaged the USB module and so I don't think it can be replaced under warranty. I received the form in early August and it worked out regularly for a week. I plan to order a new programmed USB module. I hope that with the new module it works.73 de Vincenzo

g0mjw
Posts: 888
Joined: Sat Sep 20, 2014 9:15 am

Re: No usb device - Help me -

Post by g0mjw » Thu Aug 15, 2019 5:06 pm

I don't think it is the regulators on the V2 PCB, more likely the one on the module as Vincenzo suggest, or possibly a problem with a short on one of the the IO lines. Does the module measure OK when not on the PCB? If the FT module AIC1733-33 regulator has failed, then perhaps it can be replaced?

g8vpg
Posts: 310
Joined: Fri Oct 11, 2013 9:35 am

Re: No usb device - Help me -

Post by g8vpg » Thu Aug 15, 2019 7:03 pm

Have you tried unplugging the USB module, squirting some solvent cleaner into the sockets, and re-inserting it a few times. I had this problem a few years ago and it was just dirty contacts.
73 Shaun.

iw2hxw
Posts: 7
Joined: Wed Aug 14, 2019 7:46 pm

Re: No usb device - Help me -

Post by iw2hxw » Thu Aug 15, 2019 8:40 pm

Hello,
I did these tests:
- I disconnected the ft22332h module from the pcb and connected the CN3 1 E 3 pins to power the usb at 5 volts.
- I connected the USB cable and this time the PC recognized me the device.
- I started the FT-Prog software and it recognizes the device but from an error in recognizing the eeprom (no eeprom detect blank device).
- I tried to reprogram the module but from an error.
I think it's the damaged eeprom. What do you think?
73 de Vincenzo

iw2hxw
Posts: 7
Joined: Wed Aug 14, 2019 7:46 pm

Re: No usb device - Help me -

Post by iw2hxw » Tue Sep 03, 2019 2:43 pm

Ciao, ho risolto il problema sostituendo il modulo usb .

iw2hxw
Posts: 7
Joined: Wed Aug 14, 2019 7:46 pm

Re: No usb device - Help me -

Post by iw2hxw » Tue Sep 03, 2019 2:45 pm

Hello,
rewrite the previous msg because by mistake written in Italian.
I solved the problem by replacing the USB module.

Post Reply

Return to “The MiniTiouner and MiniTioune Digital Receive Software”