Page 1 of 1

No SSH on Portsdown

Posted: Thu Sep 12, 2019 8:11 pm
by G8YTZ
I've just put together two Portsdown RPI's using the 3B+

The first one I bought the BATC SSD and no issues at all, its currently running the test GB3JV Streamer.

The second one (attached to the 7" screen) I downloaded the code from the BATC Website link and I've run into an issue:

NO SSH on the Pi.I re-downloaded the iso and re-cut the SSD 3 times, still the same issue

I connected a keyboard to kick off the installation and all is working perfectly on the touch screen, still no ssh access...

Justins-MacBook-2:~ justincockett$ ssh
ssh: connect to host port 22: Connection refused

Any ideas?

Re: No SSH on Portsdown

Posted: Fri Sep 13, 2019 2:13 pm
by M0SKM
Did you create the ssh file as per the install instructions?

Before you remove the card from your Windows PC, look at the card with windows explorer; the volume should be labeled "boot". Create a new empty file called ssh in the top-level (root) directory by right-clicking, selecting New, Text Document, and then change the name to ssh (not ssh.txt). You should get a window warning about changing the filename extension. Click OK. If you do not get this warning, you have created a file called ssh.txt and you need to rename it ssh. IMPORTANT NOTE: by default, Windows (all versions) hides the .txt extension on the ssh file. To change this, in Windows Explorer, select File, Options, click the View tab, and then untick "Hide extensions for known file types". Then click OK.


Re: No SSH on Portsdown

Posted: Fri Sep 13, 2019 3:03 pm
by G8GKQ
Hi Justin

Steve's reply covers the most likely scenario.

However, if you have already built the card, you can use the 2nd or 3rd set of instructions at serial 2 on this page to enable it: ... ccess/ssh/

Dave, G8GKQ

Re: No SSH on Portsdown

Posted: Tue Oct 08, 2019 9:46 pm
by G8YTZ
Many thanks guys! That was it! Fixed, many thanks. I'll put on my dunce hat now....